Edgewall Software
Modify

Opened 10 years ago

Closed 10 years ago

#9367 closed enhancement (duplicate)

Modify/Create a ticket responses poorly with a slow SMTP server

Reported by: anonymous Owned by:
Priority: normal Milestone:
Component: general Version: 0.12b1
Severity: normal Keywords: notification
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

With SMTP notification enabled, and a slow SMTP server, operations such as modify/create tickets will response poorly.

To improve responsivity, some asynchronous mechanism may need to be employed. In such a mechanism, pending emails may reside in a queue, and the queue may be backed by a persistent storage, in case of a sudden crash, the pending emails can be resent.

Attachment is a script which will improve responsivity. It's compatible with the "SendmailEmailSender interface". To use it, you need:

  • set mailcache dir and SMTP stuffs in the script.
  • set trac.ini:
    [notification]
    email_sender = SendmailEmailSender
    sendmail_path = /path/to/mailSender.py
    smtp_enabled = true
    

Attachments (0)

Change History (1)

comment:1 by anonymous, 10 years ago

Resolution: duplicate
Status: newclosed

Duplicate of #9368

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.