Edgewall Software
Modify

Opened 12 years ago

Closed 12 years ago

Last modified 10 years ago

#9356 closed enhancement (worksforme)

trac中Subversion权限问题

Reported by: czg_e@… Owned by:
Priority: high Milestone:
Component: version control/browser Version: 0.11.7
Severity: major Keywords: version
Cc: czg_e@… Branch:
Release Notes:
API Changes:
Internal Changes:

Description

你好:

我用的trac为:0.11.7,Subversion:1.5.7。在我给svn设置权限时,如没有给用户设置根目录的读权限则用户无法通过trac访问svn中根目录下子目录的内容。提示以下错误:

Error: Forbidden Insufficient permissions to access / privileges are required to perform this operation

如何才能不对用户设置根目录读权限,而用户能够访问根目录下子目录的内容?谢谢。

Attachments (0)

Change History (5)

comment:1 by Christian Boos, 12 years ago

Milestone: 0.11.7.1
Resolution: worksforme
Status: newclosed

This is an InstallationIssue. As the error message says, you have to add the appropriate TracPermissions to be allowed to perform the operation you were attempting to do (and next time, please try to write your report in English).

comment:2 by czg_e@…, 12 years ago

Resolution: worksforme
Status: closedreopened

Thank you,the problem is if i don't have parent directory of read then i can't read and write the directory.but i Assignment to the directory of read and write . it's only in trac wrong.svn client is ok. if i Assignment to parent directory of read ,trac is ok. my english is not good.

comment:3 by Remy Blank, 12 years ago

Resolution: worksforme
Status: reopenedclosed

Please read the InstallationIssue page, and join the MailingList or IrcChannel to get help for your installation.

comment:4 by scarecrow_7337@…, 10 years ago

I have the same problem,the permission of directory works well in svn client,but it does not work in trac webbrowser. I got two method to solve this problem.1,remove browser_view permission.2,remove file_view permission.is there any other better way?

comment:5 by Christian Boos, 10 years ago

While it's a bit hard for us to guess the specifics of this issue, a general advise would be to upgrade to 0.12.3 when it's released (#10548), as we fixed a number of issues with permissions there, notably regarding AuthzSourcePolicy.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.