Edgewall Software
Modify

Opened 12 years ago

Closed 12 years ago

Last modified 2 years ago

#9024 closed defect (worksforme)

Two queries run when clicking on a changeset

Reported by: theuni Owned by:
Priority: normal Milestone:
Component: web frontend Version: 0.11.6
Severity: normal Keywords: firefox
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

I noticed cpu usage on my mysql database (which is already very high) remains high longer than it should. It appears as though two revisions are being queried for each revision visited.

See log:

2010-02-02 22:52:41,615 Trac[main] DEBUG: Dispatching <Request "GET u'/changeset/24210'">
2010-02-02 22:52:41,622 Trac[session] DEBUG: Retrieving session for ID u'theuni'
2010-02-02 22:52:41,626 Trac[chrome] DEBUG: Prepare chrome data for request
2010-02-02 22:52:42,752 Trac[main] DEBUG: Dispatching <Request "GET u'/changeset/24211'">
2010-02-02 22:52:42,757 Trac[session] DEBUG: Retrieving session for ID u'theuni'
2010-02-02 22:52:42,762 Trac[chrome] DEBUG: Prepare chrome data for request

To reproduce: click a revision X, and see that X and X+1 are requested.

Using: trac 0.11.6, mysql, apache2+wsgi

Attachments (0)

Change History (3)

comment:1 by Remy Blank, 12 years ago

The fact that you get two GET entries in the log means that your browser actually performs these two requests, so there's nothing Trac can do about that. This is most probably due to the browser prefetching pages directly linked by a page. What browser are you using? Can you reproduce the issue with other browsers?

comment:2 by anonymous, 12 years ago

Only reproduced in firefox v3.6, after that I managed to break my install. Will try again tomorrow after I fix.

Also worth noting: only seemed to happen when logged in.

comment:3 by Christian Boos, 12 years ago

Keywords: firefox added
Resolution: worksforme
Status: newclosed

Yeah, this is Firefox specific, and you can disable that feature if this annoys you.

E.g. tips from http://www.technipages.com/disable-the-firefox-prefetch-setting.html:

  1. Type about:config in the address bar and press ENTER.
  2. Locate and double-click the entry for network.prefetch-next
  3. Set it to false to disable this feature. Double-clicking on the setting will change it.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.