Edgewall Software
Modify

Opened 10 years ago

Last modified 3 years ago

#9006 reopened defect

Tickets remain in query list until clicking "Update"

Reported by: hannu.hartikainen@… Owned by:
Priority: normal Milestone: next-stable-1.2.x
Component: report system Version: 0.11.2.1
Severity: minor Keywords: query update
Cc: Branch:
Release Notes:
API Changes:

Description

Changed tickets don't get removed from query listings unless "Update" is explicitly clicked. This seems unexpected, since you can go all the way from View tickets → [saved query] and the listing is out-of-date if you've viewed it before. This even happens if I restart my browser between viewing the query. I'm using Firefox 3.5.7 on Windows XP.

A simple way to reproduce:

  1. Create a custom query with only one filter status=closed.
  2. Reopen one of the listed closed tickets.
  3. View the query again, and see the reopened ticket still listed.

I can't really tell whether this is a bug or an undocumented feature (in which case it should just be documented). To me, the behavior seems to be caused by QueryModule's display_html not running certain SQL queries again if they were run during the last hour.

Attachments (0)

Change History (8)

comment:1 by Remy Blank, 10 years ago

Resolution: worksforme
Status: newclosed

This is intentional, as in, there is specific code in the query system to enable this functionality.

The tickets that have changed and should not be part of the query anymore are displayed in italics, IIRC. This allows, for example, to create a query, then process tickets in order, and to still know where you were when you get back to the query.

As for documenting it, please add a small paragraph in the wiki about that, at the location where you expected to find the information. Thanks!

comment:2 by hannu.hartikainen@…, 10 years ago

I had some custom css that seemed to be breaking this functionality. Thanks for help, and sorry for the bother.

The italicizing of changed tickets is explained quite well in the help, now that I knew what to look for. However, it doesn't entirely seem to reflect Trac's current behaviour:

You can safely edit any of the tickets and continue to navigate through the results using the Next/Previous/Back to Query links after saving your results. When you return to the query any tickets which were edited will be displayed with italicized text. If one of the tickets was edited such that it no longer matches the query criteria the text will also be greyed. Lastly, if a new ticket matching the query criteria has been created, it will be shown in bold.

This might be a bug: I don't see any greying or bolding on my Trac nor in http://trac.edgewall.org/demo-0.12.

in reply to:  2 comment:3 by Christian Boos, 10 years ago

Replying to hannu.hartikainen@…:

This might be a bug: I don't see any greying or bolding on my Trac nor in http://trac.edgewall.org/demo-0.12.

For a moment I had the same impression, but now it works and consistently works, so maybe there was a specific sequence of operation which didn't work? Please try again, keep exact note of what you're doing and if you manage to reproduce the problem, post the reproduction step here.

comment:4 by hannu.hartikainen@…, 10 years ago

Okay, here goes for greying:

  1. Open http://trac.edgewall.org/demo-0.12/query?status=closed in one browser tab.
  2. Click Update (to ensure a clean state).
  3. Open one of the listed tickets in another browser tab.
  4. Reopen the ticket.
  5. Refresh the query page in the first tab.

I constantly get the italics but haven't seen any greying this far. The bolding seems to work, I just misunderstood it at first.

in reply to:  4 comment:5 by Remy Blank, 10 years ago

Replying to hannu.hartikainen@…:

  1. Open http://trac.edgewall.org/demo-0.12/query?status=closed in one browser tab.

(snip)

I constantly get the italics but haven't seen any greying this far.

Mmh, if all tickets in the query are closed already, it doesn't really make sense to grey anything out, does it?

OTOH, I just tried with a query of open tickets, and I don't see any greying either. The row only gets the changed class, which makes it italicized.

comment:6 by Ryan J Ollos, 4 years ago

Milestone: next-stable-1.0.x
Resolution: worksforme
Status: closedreopened

gmessage:trac-dev:PgVVglIpItQ/IDYuryf1CwAJ raises questions similar to those in comment:description.

Reopening to address the defect described in comment:5, which I've confirmed exists on 1.0-stable.

comment:7 by Peter Suter, 4 years ago

I think the greying was removed in changeset:6792. I'd consider updating the documentation instead of reinstating it. (At least if performance suffers noticeably.)

It might also make sense to explain this feature on the query result page somehow. (Maybe change the tooltip of such rows? Or add a legend, similar to the color legend found on changesets / logs? Or a green notice bar?)

comment:8 by Ryan J Ollos, 3 years ago

Milestone: next-stable-1.0.xnext-stable-1.2.x

Moved ticket assigned to next-stable-1.0.x since maintenance of 1.0.x is coming to a close. Please move the ticket back if it's critical to fix on 1.0.x.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as reopened The ticket will remain with no owner.
The ticket will be disowned. Next status will be 'new'.
as The resolution will be set. Next status will be 'closed'.
The owner will be changed from (none) to anonymous. Next status will be 'assigned'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.