Edgewall Software
Modify

Opened 17 years ago

Closed 17 years ago

Last modified 6 years ago

#890 closed enhancement (duplicate)

Some ticket changes are not visible in the Timeline

Reported by: Christian Boos Owned by: Jonas Borgström
Priority: normal Milestone:
Component: timeline Version: devel
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

I suppose that it is on purpose that the comments added to tickets are not shown in the timeline…

However, I see at 2 problems with that approach:

  • The timeline filter says Ticket changes yes/no, which is misleading
  • When you add something meaningful to an old ticket, chances are high that this won't be noticed for a while…

For instance, I made a contribution (an interesting one, imho) to #234. To be sure that this will get noticed, I could have created a new ticket for it (*) linking to the old one for good measure, or announced it on the mailing-list…

But wouldn't it be simpler if it was shown as a ticket change in the timeline?

Possible solution:

  • Change the current filtername from "Ticket changes" to "Tickets status changes"
  • Add another filter "Ticket contributions", which enables/disables viewing the added comments

(*) one could argue that this was indeed what I've done :)

Attachments (2)

ticket_comments_in_timeline.1017.diff (6.8 KB ) - added by cboos@… 17 years ago.
patch that does the proposed solution
Timeline.py.diff (4.4 KB ) - added by Arthur.Ward@… 17 years ago.
Updated diff for Timeline.py that applies against 0.8.1

Download all attachments as: .zip

Change History (6)

by cboos@…, 17 years ago

patch that does the proposed solution

comment:1 by Matthew Good <matt-good.net>, 17 years ago

Resolution: duplicate
Status: newclosed

This is a duplicate of #662. I'll include a link back here for the patch.

comment:2 by Florent Guillaume <fg@…>, 17 years ago

Cc: fg@… added

by Arthur.Ward@…, 17 years ago

Attachment: Timeline.py.diff added

Updated diff for Timeline.py that applies against 0.8.1

comment:3 by anonymous, 16 years ago

Cc: fg@… removed

comment:4 by Ryan J Ollos, 6 years ago

Reporter: changed from cboos@… to Christian Boos

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.