Edgewall Software
Modify

Opened 10 years ago

Closed 3 years ago

#8812 closed enhancement (duplicate)

Text field with post-label and right alignment

Reported by: guido.stet@… Owned by:
Priority: normal Milestone:
Component: ticket system Version: none
Severity: normal Keywords: fieldrefactoring
Cc: Branch:
Release Notes:
API Changes:

Description (last modified by Christian Boos)

The TH:TimingAndEstimation plugin uses text fields as number fields.

Either allow for a proper number inputfield or extend the text field to allow for:

  • a right alignment of the value
  • an post-label that can be used as an unit

Attachments (2)

TracCustomNumberField.jpg (61.5 KB ) - added by anonymous 10 years ago.
TicketSystem_CustomField_Align_PostLabel_DisplaySize_ChangeSet.patch (2.0 KB ) - added by guidostet@… 10 years ago.

Download all attachments as: .zip

Change History (8)

by anonymous, 10 years ago

Attachment: TracCustomNumberField.jpg added

comment:1 by Christian Boos, 10 years ago

Component: generalticket system
Description: modified (diff)
Keywords: fieldrefactoring added
Milestone: next-major-0.1X

Patch welcomed ;-)

comment:2 by guido.stet@…, 10 years ago

With the attached change-set custom fields have the following attributes added:

  • align: optional alignment (left(default), right)
  • post_label: optional, a label after the field. This can be used as a unit notation.
  • display_size: optional, the size or number of characters the field displays.

comment:3 by Christian Boos, 10 years ago

Oh well, next time I should be more precise about what kind of patch would be welcomed ;-)

I was more expecting something along the line of the first solution allow for a proper number inputfield rather than the second, which looks a bit too hackish… (not the patch which is fine, but the approach).

Sorry for the inconvenience, in the meantime I'm sure the patch could be useful for other people having the same immediate needs.

comment:4 by Remy Blank, 10 years ago

Milestone: next-major-0.1Xunscheduled

comment:5 by Peter Suter, 3 years ago

allow for a proper number inputfield

Possible duplicate of #10040?

comment:6 by Ryan J Ollos, 3 years ago

Milestone: unscheduled
Resolution: duplicate
Status: newclosed

Closing as duplicate of #10040.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.