Edgewall Software
Modify

Opened 13 years ago

Closed 13 years ago

#8788 closed defect (duplicate)

Failed trac-admin initenv

Reported by: robi@… Owned by:
Priority: high Milestone:
Component: general Version: none
Severity: normal Keywords: needinfo
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description (last modified by Christian Boos)

vu000033:~# trac-admin /home/trac initenv
Creating a new Trac environment at /home/trac

Trac will first ask a few questions about your environment
in order to initalize and prepare the project database.

 Please enter the name of your project.
 This name will be used in page titles and descriptions.

Project Name [My Project]>

 Please specify the connection string for the database to use.
 By default, a local SQLite database is created in the environment
 directory. It is also possible to use an already existing
 PostgreSQL database (check the Trac documentation for the exact
 connection string syntax).

Database connection string [sqlite:db/trac.db]>

 Please specify the type of version control system,
 By default, it will be svn.

 If you don't want to use Trac with version control integration,
 choose the default here and don't specify a repository directory.
 in the next question.

Repository type [svn]>

 Please specify the absolute path to the version control
 repository, or leave it blank to use Trac without a repository.
 You can also set the repository location later.

Path to repository [/path/to/repos]> /home/svn

 Please enter location of Trac page templates.
 Default is the location of the site-wide templates installed with Trac.

Templates directory [/usr/share/trac/templates]>

Creating and Initializing Project
...

Failed to initialize environment. ('No such revision 1', 160006)
Traceback (most recent call last):
  File "/var/lib/python-support/python2.4/trac/scripts/admin.py", line 628, in do_initenv
    repos = self.__env.get_repository()
  File "/var/lib/python-support/python2.4/trac/env.py", line 195, in get_repository
    return RepositoryManager(self).get_repository(authname)
  File "/var/lib/python-support/python2.4/trac/versioncontrol/api.py", line 101, in get_repository
    repos = self._connector.get_repository(rtype, rdir, authname)
  File "/var/lib/python-support/python2.4/trac/versioncontrol/svn_fs.py", line 260, in get_repository
    crepos = CachedRepository(self.env.get_db_cnx(), repos, None, self.log)
  File "/var/lib/python-support/python2.4/trac/versioncontrol/cache.py", line 39, in __init__
    self.sync()
  File "/var/lib/python-support/python2.4/trac/versioncontrol/cache.py", line 143, in sync
    cset = self.repos.get_changeset(next_youngest)
  File "/var/lib/python-support/python2.4/trac/versioncontrol/svn_fs.py", line 346, in get_changeset
    self.fs_ptr, self.pool)
  File "/var/lib/python-support/python2.4/trac/versioncontrol/svn_fs.py", line 638, in __init__
    message = self._get_prop(core.SVN_PROP_REVISION_LOG)
  File "/var/lib/python-support/python2.4/trac/versioncontrol/svn_fs.py", line 729, in _get_prop
    return fs.revision_prop(self.fs_ptr, self.rev, name, self.pool())
  File "/var/lib/python-support/python2.4/libsvn/fs.py", line 570, in svn_fs_revision_prop
    return apply(_fs.svn_fs_revision_prop, args)
SubversionException: ('No such revision 1', 160006)
vu000033:~# chown -R www-data /home/trac/

Attachments (0)

Change History (3)

comment:1 by Christian Boos, 13 years ago

Description: modified (diff)
Keywords: needinfo added

Which Trac version?

Is /home/svn really a Subversion repository or does it contain subversion repository?

If it's really a valid repos, is it an empty one or do you have some revisions inside?

Also, check the permissions on that repository (you must be able to access it read-only).

comment:2 by robi@…, 13 years ago

trac_0.10.3-1etch4_all.deb

/home/svn is a really a Subversion repository, it's not empty, i tried with empty and not empty

i tried with permissions both writable and read-only

comment:3 by Christian Boos, 13 years ago

Resolution: duplicate
Status: newclosed

Well, trac_0.10.3-1etch4_all.deb is not supported anymore.

Your issue is most likely a duplicate of #4937, you should therefore upgrade to 0.10.4 or 0.10.5, at least (TracDownload#PreviousStableRelease?).

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.