Edgewall Software
Modify

Opened 17 years ago

Closed 17 years ago

Last modified 15 years ago

#876 closed defect (duplicate)

Possibility to set reassign field to a drop down list.

Reported by: tonib Owned by: Jonas Borgström
Priority: normal Milestone:
Component: ticket system Version: devel
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

It would be nice if it would be possible to set the reassign field to a drop down list.

For example through trac.ini. Something like:

[notification]
reasssign_list = person1, person2, person3

Attachments (1)

dropdown.diff (4.9 KB ) - added by muti@… 17 years ago.
Dropdown List

Download all attachments as: .zip

Change History (6)

comment:1 by anonymous, 17 years ago

Component: generalticket system
Version: 0.7.1devel

comment:2 by muti@…, 17 years ago

Attached is a patch that will grab the list of users from the session table and add to a dropdown list. The session table gets cleared automatically after the record has been dormant for 90 days so I added a variable to trac.ini under the [trac] section named disable_session_purge which can be set true or false (defaults to false).

This modifies the assign-to and the re-assign field.

by muti@…, 17 years ago

Attachment: dropdown.diff added

Dropdown List

comment:3 by jburley, 17 years ago

Unfortunately, this didn't work right out of the box for me on Win32. After patching the necessary files the dropdown on the New Ticket page was empty.

I tried going back in and saving my settings, but that did not help.

Any ideas?

comment:4 by Josh Burley <jburley@…>, 17 years ago

Note: on windows, for my install, I had to recompile Ticket.py by hand… removing Ticket.pyc was not sufficient… weird, eh? :)

comment:5 by Christopher Lenz, 17 years ago

Resolution: duplicate
Status: newclosed

This is actually a duplicate of #222.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.