Edgewall Software
Modify

Opened 16 years ago

Closed 16 years ago

#875 closed defect (worksforme)

Rendering bug in Firefox

Reported by: anonymous Owned by: Christopher Lenz
Priority: low Milestone:
Component: version control/changeset view Version: devel
Severity: minor Keywords: layout
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description (last modified by Christopher Lenz)

In the diff view, it sometimes happens that the content column gets very narrow, in Firefox (Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10.1).

I noticed this bug first on my trac, but now it also shows up on the edgewall trac for changeset [1010], so I take this opportunity to create a ticket for it.

Most certainly it's a bug in Firefox, but maybe some CSS wizard will find a workaround for this…

Pictures showing the bug attached:

  • Abnormal rendering in Firefox:

http://projects.edgewall.com/trac/attachment/ticket/875/ff_1010.png?format=raw

attachment:ff_1010.png

  • Normal rendering in IE:

http://projects.edgewall.com/trac/attachment/ticket/875/ie_1010.png?format=raw

attachment:ie_1010.png

Attachments (2)

ff_1010.png (24.5 KB ) - added by cboos@… 16 years ago.
Firefox rendering of [1010]
ie_1010.png (27.2 KB ) - added by cboos@… 16 years ago.
IE rendering of [1010]

Download all attachments as: .zip

Change History (10)

by cboos@…, 16 years ago

Attachment: ff_1010.png added

Firefox rendering of [1010]

by cboos@…, 16 years ago

Attachment: ie_1010.png added

IE rendering of [1010]

comment:1 by matthew@…, 16 years ago

For what it's worth, it renders fine for me on 1.0RC1 and 1.0RC2.

comment:2 by anonymous, 16 years ago

Works for me on Firefox 1.0PR and Linux

comment:3 by Christopher Lenz, 16 years ago

Component: generalchangeset view
Description: modified (diff)
Keywords: layout added
Owner: changed from Jonas Borgström to Christopher Lenz
Status: newassigned

Works for me on Firefox 1.0RC1 on Windows and Mac OS X.

Is this problem consistently reproducible over the same changesets, or does it go away on reload etc. What is the exact version of Firefox you're using, and on what platform?

comment:4 by Christopher Lenz, 16 years ago

Forget the question about the version/platform. I should have read the description properly :-P

comment:5 by cboos@…, 16 years ago

I upgrated to Firefox 1.0, and it still doesn't work for me… Strange.

comment:6 by cboos@…, 16 years ago

The bug shows up also in [1073].

comment:7 by cboos@…, 16 years ago

Also, when I save the file source locally, and change it so that it uses the CSS from my local trac installation (rev [1061]), the page is rendered correctly. So it's quite difficult to debug :)

comment:8 by cboos@…, 16 years ago

Resolution: worksforme
Status: assignedclosed

More fun with this issue:

  • While browsing [1327] (the latest at this time), I noticed the display problem once again, so I decided to try the Web Developer extension Edit CSS… feature to see if I could improve things… and the simple fact of launching the editor did solve the layout problem!
  • I tried to quit/restart Firefox: it was still OK
  • I can even see [1010] and [1073] without any problem now

So, whatever was that bug, I think that now it works for me :)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Christopher Lenz.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Christopher Lenz to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.