Edgewall Software
Modify

Opened 13 years ago

Closed 13 years ago

#8733 closed defect (worksforme)

OperationalError: database or disk is full

Reported by: jims Owned by:
Priority: highest Milestone:
Component: general Version: 0.11.4
Severity: blocker Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

How to Reproduce

While doing a GET operation on /login, Trac issued an internal error.

(please provide additional details here)

User Agent was: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.14) Gecko/2009090216 Ubuntu/9.04 (jaunty) Firefox/3.0.14

System Information

Trac 0.11.4
Python 2.5.2 (r252:60911, Jan 4 2009, 18:00:02)
[GCC 4.3.2]
setuptools 0.6c8
SQLite 3.5.9
pysqlite 2.4.1
Genshi 0.5.1
Pygments 0.10
GIT 1.6.2.4
Subversion 1.6.1 (r37116)
jQuery: 1.2.6

Python Traceback

Traceback (most recent call last):
  File "/usr/local/lib/python2.5/site-packages/Trac-0.11.4-py2.5.egg/trac/web/main.py", line 435, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/local/lib/python2.5/site-packages/Trac-0.11.4-py2.5.egg/trac/web/main.py", line 205, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/local/lib/python2.5/site-packages/Trac-0.11.4-py2.5.egg/trac/web/auth.py", line 101, in process_request
    self._do_login(req)
  File "/usr/local/lib/python2.5/site-packages/Trac-0.11.4-py2.5.egg/trac/web/auth.py", line 141, in _do_login
    req.remote_addr, int(time.time())))
  File "/usr/local/lib/python2.5/site-packages/Trac-0.11.4-py2.5.egg/trac/db/util.py", line 50, in execute
    return self.cursor.execute(sql_escape_percent(sql), args)
  File "/usr/local/lib/python2.5/site-packages/Trac-0.11.4-py2.5.egg/trac/db/sqlite_backend.py", line 58, in execute
    args or [])
  File "/usr/local/lib/python2.5/site-packages/Trac-0.11.4-py2.5.egg/trac/db/sqlite_backend.py", line 50, in _rollback_on_error
    return function(self, *args, **kwargs)
OperationalError: database or disk is full

Attachments (0)

Change History (3)

in reply to:  description comment:1 by Remy Blank, 13 years ago

Resolution: invalid
Status: newclosed

Replying to jims:

OperationalError: database or disk is full

Mmh… And what exactly do you expect us to do about that? ;-)

comment:2 by anonymous, 13 years ago

Resolution: invalid
Status: closedreopened

Mmh….I did nothing to fix this, our disk usage has been < 1% of our storage. It fixed itself over time which is disconcerting to me because when this happened it completely shut me down from doing work as I could not get access to any of the repository via my web browser.

What changes did you make to fix this problem or was the problem ours and you fixed it in which case tell us what we did so we do not repeat this in the future.

comment:3 by Christian Boos, 13 years ago

Resolution: worksforme
Status: reopenedclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.