Edgewall Software
Modify

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#8665 closed defect (wontfix)

AttributeError: 'NoneType' object has no attribute 'values'

Reported by: iain@… Owned by:
Priority: high Milestone:
Component: general Version: 0.11.5
Severity: critical Keywords:
Cc: andrea.tomasini@…, felix.schwarz@… Branch:
Release Notes:
API Changes:

Description

How to Reproduce

While doing a GET operation on /query, Trac issued an internal error.

Request parameters:

{'col': [u'id',
         u'summary',
         u'story_priority',
         u'component',
         u'status',
         u'type',
         u'priority',
         u'milestone'],
 'component': [u'!', u'!'],
 'group': u'story_priority',
 'order': u'priority',
 'report': u'10',
 'sprint': u'Sprint 7',
 'status': [u'accepted', u'assigned', u'new', u'reopened'],
 'type': u'!'}

User Agent was: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729)

System Information

Trac 0.11.5
Python 2.6.2 (r262:71605, Apr 14 2009, 22:40:02) [MSC v.1500 32 bit (Intel)]
setuptools 0.6c9
SQLite 3.5.9
pysqlite 2.4.1
Genshi 0.5.1
Pygments 1.0
jQuery: 1.2.6

Python Traceback

Traceback (most recent call last):
  File "C:\Python26\lib\site-packages\trac-0.11.5-py2.6-win32.egg\trac\web\main.py", line 444, in _dispatch_request
    dispatcher.dispatch(req)
  File "C:\Python26\lib\site-packages\trac-0.11.5-py2.6-win32.egg\trac\web\main.py", line 205, in dispatch
    resp = chosen_handler.process_request(req)
  File "C:\Python26\lib\site-packages\trac-0.11.5-py2.6-win32.egg\trac\ticket\query.py", line 761, in process_request
    constraints = self._get_constraints(req)
  File "C:\Python26\lib\site-packages\trac-0.11.5-py2.6-win32.egg\trac\ticket\query.py", line 841, in _get_constraints
    TicketSystem(self.env).get_ticket_fields()]
  File "C:\Python26\lib\site-packages\agilo-0.8.2.0.2_r1872_20090828-py2.6.egg\agilo\ticket\api.py", line 333, in get_ticket_fields
    t_type = self.normalize_type(t_type, new_aliases)
  File "C:\Python26\lib\site-packages\agilo-0.8.2.0.2_r1872_20090828-py2.6.egg\agilo\ticket\api.py", line 192, in normalize_type
    self._alias_to_type = dict(zip(self._alias_mapping.values(), self._alias_mapping.keys()))
AttributeError: 'NoneType' object has no attribute 'values'

Attachments (0)

Change History (4)

comment:1 by Remy Blank, 10 years ago

Cc: andrea.tomasini@… added
Resolution: wontfix
Status: newclosed

PluginIssue (Agilo).

in reply to:  1 comment:2 by andrea.tomasini@…, 10 years ago

Replying to rblank:

PluginIssue (Agilo).

Got it… please follow it up here: https://dev.agile42.com/ticket/896 from now on :-)

Thanks ANdreaT

comment:3 by Felix Schwarz <felix.schwarz@…>, 10 years ago

Cc: felix.schwarz@… added

Just a question to the original reporter: Is this in a multi-environment trac?

in reply to:  3 comment:4 by anonymous, 10 years ago

Replying to Felix Schwarz <felix.schwarz@…>:

Just a question to the original reporter: Is this in a multi-environment trac?

No it's not. I installed a new plugin on Friday, typeticketworkflow and it was working fine. I then came in yesterday and the application stopped working and un-enabled the new plugin. We restarte the App this morning and it seems to be working now.

Thanks for looking into this anyway! Iain

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.