Edgewall Software
Modify

Opened 15 years ago

Closed 14 years ago

#860 closed enhancement (worksforme)

Make the legend in changeset view horizontal in Opera as well

Reported by: agr30@… Owned by: Jonas Borgström
Priority: lowest Milestone:
Component: version control/changeset view Version: devel
Severity: normal Keywords: layout
Cc: Branch:
Release Notes:
API Changes:

Description (last modified by Christopher Lenz)

The legend in changeset view has the elements centered above each other in Opera instead of being a horizontal line. This patch fixes this. Tested on Opera 7.5, Firefox 0.9 (both Linux) and Internet Explorer 6.0

--- changeset.cs.old    2004-10-30 03:00:01.000000000 +0200
+++ changeset.cs        2004-10-30 03:01:40.000000000 +0200
@@ -100,6 +100,7 @@
    <dt class="rem"></dt><dd>Removed</dd>
    <dt class="mod"></dt><dd>Modified</dd>
   </dl>
+  <br /> 
  </div>
  <ul>
   <?cs each:file = changeset.diff.files ?>

--- diff.css.old        2004-10-30 03:02:36.000000000 +0200
+++ diff.css    2004-10-30 03:05:57.000000000 +0200
@@ -40,12 +40,13 @@
  width: .8em; height: .8em;
 }
 .diff #legend dl, .diff #legend dd {
- display: inline;
- float: left;
  padding: 0;
  margin: 0;
  margin-right: .5em;
 }
+.diff #legend dd { 
+ float: left;
+}
 
 /* Styles for the list of diffs */
 .diff ul { clear: both; margin: 0; padding: 0 }

Attachments (0)

Change History (7)

comment:1 by anonymous, 15 years ago

Version: 0.7.1devel

comment:2 by Christopher Lenz, 14 years ago

Milestone: 0.9.1

comment:3 by Christopher Lenz, 14 years ago

Description: modified (diff)
Milestone: 0.9.10.9.2

comment:4 by Christopher Lenz, 14 years ago

Milestone: 0.9.30.9.4

comment:5 by Jonas Borgström, 14 years ago

Milestone: 0.9.40.10

I was not able to reproduce this particular problem with opera 8.51 (build 1462) but I noticed quite a few other layout problems with opera (the changeset and roadmap page for example).

Defering this to 0.10.

comment:6 by Christian Boos, 14 years ago

Just a quick note here to mention that Opera version 8.54 / System Windows XP seems to work fine, except

  • for the Changeset View, where the description list for the changeset property is a bit messed up (the <dt>s are not aligned with their corresponding <dd> and overlap with the diffs).
  • for the tickets, where the Change Properties fieldset is too narrow and the spanning fields like summary an description, as well as all the fields from the second column are overlapping.

The legend and the roadmap look fine, though.

comment:7 by Christian Boos, 14 years ago

Milestone: 0.10
Resolution: worksforme
Status: newclosed

For the Changeset View issue, see #1288, which has also a screenshot showing the problem.

As the legend is now displayed horizontally in Opera, I think we can close this one.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.