Edgewall Software
Modify

Opened 15 years ago

Closed 13 years ago

#1288 closed defect (worksforme)

Display of changeset page in source browser is fixed in GECKO-based browsers, still disturbed in Opera and Konqueror

Reported by: peter.fischer@… Owned by: Christopher Lenz
Priority: normal Milestone:
Component: version control/changeset view Version: devel
Severity: normal Keywords: layout patch
Cc: peter.fischer@… Branch:
Release Notes:
API Changes:
Internal Changes:

Description

Thank you for fixing #1087 a.k.a #1129. While testing if 8.1 will work for me (and my fellow colleagues) I found these:

Changesetpage_in_FireFox1.0.jpg (okay, for comparison) Changesetpage_in_Konqueror3.3.jpg (table for diff display broken) Changesetpage_in_Opera7.54.jpg (Author/Messages/Files and colour legend wrong placed) Changesetpage_in_Opera8beta.jpg (Author/Messages/Files wrong placed)

Tested with browsers mentioned in screenshot title on linux and W2k-SP4 (except Konqueror on W2k and IE on linux ;) ).

IE on W2k displays ok, except for the font size of the Home/Download/Documentation/… menu on the left, but who does use IE anyway?

Attachments (4)

Changesetpage_in_FireFox1.0.jpg (151.0 KB ) - added by peter.fischer@… 15 years ago.
Changesetpage_in_Konqueror3.3.jpg (152.0 KB ) - added by peter.fischer@… 15 years ago.
Changesetpage_in_Opera7.54.jpg (155.4 KB ) - added by peter.fischer@… 15 years ago.
Changesetpage_in_Opera8beta.jpg (157.9 KB ) - added by peter.fischer@… 15 years ago.

Download all attachments as: .zip

Change History (19)

by peter.fischer@…, 15 years ago

by peter.fischer@…, 15 years ago

by peter.fischer@…, 15 years ago

by peter.fischer@…, 15 years ago

comment:1 by Christopher Lenz, 15 years ago

Component: browserchangeset view
Keywords: layout added

See #1246 for more on the Konqueror problem.

comment:2 by Christopher Lenz, 15 years ago

Owner: changed from Jonas Borgström to Christopher Lenz

comment:3 by nil4, 15 years ago

Version: 0.8.1devel

The following diff.css snippet displays changesets perfectly in Opera 8.0b3, Firefox 1.0.1 and IE 6.0. The only catch is that this only works as long as the <dd> tags are not empty (need a nbsp instead of the empty value).

#overview dt {
 font-weight: bold;
 padding-right: .25em;
/* position: absolute;
 left: 0;*/
 text-align: right;
 width: 7.75em;
 float: left;
}
#overview dd { margin-left: 8.2em }

Sorry for not posting a diff, I'm not familiar with that. Hope it helps.

comment:4 by Christopher Lenz, 15 years ago

Milestone: 0.9.1
Status: newassigned

comment:5 by Christopher Lenz, 15 years ago

Milestone: 0.9.10.9.2

comment:6 by Christopher Lenz, 15 years ago

Milestone: 0.9.30.9.4

comment:7 by Matthew Good, 15 years ago

Keywords: patch added

Combining the above style with some CSS hacks preserves the layout when the <dd>s are empty:

  • htdocs/css/diff.css

    ==================================================================
     
    1010#overview dt {
    1111 font-weight: bold;
    1212 padding-right: .25em;
    13  position: absolute;
    14  left: 0;
     13 float: left;
    1514 text-align: right;
    1615 width: 7.75em;
    1716}
    18 #overview dd { margin-left: 8em }
     17#overview dd { margin-left: 8.2em }
     18/* Fix for empty DDs */
     19#overview dd:after {
     20 content: ".";
     21 display: block;
     22 height: 0;
     23 clear: left;
     24 visibility: hidden;
     25}
     26/* Hide from IE-mac \*/
     27* html .clearfix { height: 1%; }
     28/* End fix for empty DDs */
    1929
    2030/* Colors for change types */
    2131#chglist .edit, #overview .mod, .diff #legend .mod { background: #fd8 }

I'll leave this open for alternatives since this hack is a bit ugly.

comment:8 by fate, 15 years ago

As far as I can tell the code change to diff.css below displays the changeset properly in Opera 8.02, IE 6 and Firefox 1.5. It works even when the dd tags are empty.

#overview dt {
 font-weight: bold;
 padding-right: .25em;
 /*position: absolute;*/
 left: 0;
 float:left;
 clear:left;
 text-align: right;
 width: 7.75em;
}

comment:9 by Jonas Borgström, 14 years ago

#2715 has been marked as a duplicate of this ticket.

comment:10 by Christopher Lenz, 14 years ago

Milestone: 0.9.40.9.5

Sorry, still not going to make it into 0.9.4… postponing again.

comment:11 by Christopher Lenz, 14 years ago

Milestone: 0.9.50.10

comment:12 by Christian Boos, 14 years ago

Milestone: 0.100.11
Owner: changed from Christopher Lenz to Christian Boos
Status: assignednew

Removing the position: absolute seems to break the layout for IExplorer and Firefox (fate, did you forget to force reload after the CSS change?)

Opera 9beta preview 2 still has the bug, but I noticed that using its Print preview mode (Shift-P), the <dt> are correctly rendered.

So I'd propose to postpone this a bit more, as I don't see that as a blocker for 0.10.

comment:13 by Christian Boos, 14 years ago

Owner: changed from Christian Boos to Christopher Lenz

(didn't meant to assign it to me)

comment:14 by Christian Boos, 14 years ago

Opera 9 (win32, Build 8502) seems to be doing fine on Changesets now!

comment:15 by Christian Boos, 13 years ago

Milestone: 0.11
Resolution: worksforme
Status: newclosed

Seems to work well for all major browsers now.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Christopher Lenz.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Christopher Lenz to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.