Edgewall Software
Modify

Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#8563 closed defect (wontfix)

TypeError: <lambda>() got multiple values for keyword argument 'type'

Reported by: andreas.r.johansson@… Owned by:
Priority: normal Milestone:
Component: general Version: 0.11.4
Severity: normal Keywords:
Cc: andrea.tomasini@… Branch:
Release Notes:
API Changes:
Internal Changes:

Description

How to Reproduce

While doing a GET operation on /ticket/2, Trac issued an internal error.

While trying to edit a ticket this traceback is displayed. The product is actually Agilo for scrum 1.0 and I'm not sure this bug is specific to Trac but any help is appreciated.

Request parameters:

{'id': u'2', 'pane': u'edit'}

User Agent was: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2 (.NET CLR 4.0.20506)

System Information

Trac 0.11.4
Python 2.5.4 (r254:67916, Dec 23 2008, 15:10:54) [MSC v.1310 32 bit (Intel)]
setuptools 0.6c9
MySQL server: "5.1.34-community", client: "5.0.27", thread-safe: 1
MySQLdb 1.2.2
Genshi 0.5.1
Agilo 1.0.1-pro
jQuery: 1.2.6

Python Traceback

Traceback (most recent call last):
  File "C:\Documents and Settings\taz.TAZWIN\Desktop\Agilo_installer\trac_svn\lib\site-packages\trac-0.11.4-py2.5.egg\trac\web\main.py", line 435, in _dispatch_request
  File "C:\Documents and Settings\taz.TAZWIN\Desktop\Agilo_installer\trac_svn\lib\site-packages\trac-0.11.4-py2.5.egg\trac\web\main.py", line 227, in dispatch
  File "C:\Documents and Settings\taz.TAZWIN\Desktop\Agilo_installer\trac_svn\lib\site-packages\trac-0.11.4-py2.5.egg\trac\web\chrome.py", line 742, in render_template
  File "build\bdist.win32\egg\genshi\core.py", line 179, in render
    return encode(generator, method=method, encoding=encoding, out=out)
  File "build\bdist.win32\egg\genshi\output.py", line 61, in encode
    for chunk in iterator:
  File "build\bdist.win32\egg\genshi\output.py", line 311, in __call__
    for kind, data, pos in stream:
  File "build\bdist.win32\egg\genshi\output.py", line 753, in __call__
    for kind, data, pos in stream:
  File "build\bdist.win32\egg\genshi\output.py", line 592, in __call__
    for kind, data, pos in stream:
  File "build\bdist.win32\egg\genshi\output.py", line 698, in __call__
    for kind, data, pos in chain(stream, [(None, None, None)]):
  File "build\bdist.win32\egg\genshi\output.py", line 532, in __call__
    for ev in stream:
  File "build\bdist.win32\egg\genshi\core.py", line 283, in _ensure
    for event in stream:
  File "build\bdist.win32\egg\genshi\core.py", line 283, in _ensure
    for event in stream:
  File "C:\Documents and Settings\taz.TAZWIN\Desktop\Agilo_installer\trac_svn\lib\site-packages\trac-0.11.4-py2.5.egg\trac\web\chrome.py", line 807, in _strip_accesskeys
  File "build\bdist.win32\egg\genshi\core.py", line 283, in _ensure
    for event in stream:
  File "C:\Documents and Settings\taz.TAZWIN\Desktop\Agilo_installer\trac_svn\lib\site-packages\trac-0.11.4-py2.5.egg\trac\web\chrome.py", line 796, in _generate
  File "build\bdist.win32\egg\genshi\template\base.py", line 582, in _include
    for event in tmpl.generate(ctxt, **vars):
  File "build\bdist.win32\egg\genshi\template\base.py", line 569, in _include
    for event in stream:
  File "build\bdist.win32\egg\genshi\template\markup.py", line 298, in _match
    ctxt, start=idx + 1, **vars):
  File "build\bdist.win32\egg\genshi\template\markup.py", line 298, in _match
    ctxt, start=idx + 1, **vars):
  File "build\bdist.win32\egg\genshi\template\markup.py", line 245, in _match
    for event in stream:
  File "build\bdist.win32\egg\genshi\template\base.py", line 543, in _exec
    for event in stream:
  File "build\bdist.win32\egg\genshi\template\base.py", line 533, in _eval
    for event in substream:
  File "build\bdist.win32\egg\genshi\template\base.py", line 496, in _eval
    for kind, data, pos in stream:
  File "build\bdist.win32\egg\genshi\template\base.py", line 551, in _flatten
    for event in stream:
  File "build\bdist.win32\egg\genshi\core.py", line 283, in _ensure
    for event in stream:
  File "build\bdist.win32\egg\genshi\path.py", line 141, in _generate
    subevent = stream.next()
  File "build\bdist.win32\egg\genshi\template\base.py", line 569, in _include
    for event in stream:
  File "build\bdist.win32\egg\genshi\template\markup.py", line 298, in _match
    ctxt, start=idx + 1, **vars):
  File "build\bdist.win32\egg\genshi\template\markup.py", line 298, in _match
    ctxt, start=idx + 1, **vars):
  File "build\bdist.win32\egg\genshi\template\markup.py", line 245, in _match
    for event in stream:
  File "build\bdist.win32\egg\genshi\template\base.py", line 543, in _exec
    for event in stream:
  File "build\bdist.win32\egg\genshi\template\base.py", line 533, in _eval
    for event in substream:
  File "build\bdist.win32\egg\genshi\template\base.py", line 510, in _eval
    **vars):
  File "build\bdist.win32\egg\genshi\template\base.py", line 520, in _eval
    result = _eval_expr(data, ctxt, **vars)
  File "build\bdist.win32\egg\genshi\template\base.py", line 286, in _eval_expr
    retval = expr.evaluate(ctxt)
  File "build\bdist.win32\egg\genshi\template\eval.py", line 180, in evaluate
    return eval(self.code, _globals, {'__data__': data})
  File "c:\agilo\lib\site-packages\binary_agilo-1.0.1_pro-py2.5.egg\agilo\ticket\links\templates\agilo_links_edit.html", line 65, in <Expression u'href.newticket(type=item.dest_type, src=ticket.id, **copied_fields)'>
    <li><a href="${href.newticket(type=item.dest_type, src=ticket.id, **copied_fields)}">Create a new referenced '${ticket.get_alias(item.dest_type)}'</a></li>
TypeError: <lambda>() got multiple values for keyword argument 'type'

Attachments (0)

Change History (5)

comment:1 by Christian Boos, 13 years ago

Resolution: wontfix
Status: newclosed

No, this is really specific to AgiloForScrum (agilo_links_edit.html is one of their templates).

comment:2 by andreas.r.johansson@…, 13 years ago

Thanks for the prompt reply, I will contact Agile42 about the issue.

in reply to:  1 ; comment:3 by andrea.tomasini@…, 13 years ago

Cc: andrea.tomasini@… added

Replying to cboos: Hi Christian,

No, this is really specific to AgiloForScrum (agilo_links_edit.html is one of their templates).

Isn't there a way by which you can forward me these emails or just put me in cc when some AgiloForScrum things are popping up?

Thanks :-)

in reply to:  3 ; comment:4 by Christian Boos, 13 years ago

Replying to andrea.tomasini@…:

Replying to cboos: Hi Christian,

No, this is really specific to AgiloForScrum (agilo_links_edit.html is one of their templates).

Isn't there a way by which you can forward me these emails or just put me in cc when some AgiloForScrum things are popping up?

Ok, I'll CC you, but I think we should rather reactivate #5516 ;-)

The idea in the patches there was that you could directly get the semi-automated bug reports in a Trac corresponding to the faulty plugin, or failing that, at least give proper mail contact and avoid semi-automated bug reports to be created on t.e.o's Trac.

Maybe even simpler: I don't know if you're re-packaging Trac itself, pristine distribution or with some patches - if so, you could modify the URL for the semi-automated bug report so that it goes to one of yours instead of t.e.o.

in reply to:  4 comment:5 by andrea.tomasini@…, 13 years ago

Replying to cboos:

Replying to andrea.tomasini@…:

Replying to cboos: Hi Christian,

No, this is really specific to AgiloForScrum (agilo_links_edit.html is one of their templates).

Isn't there a way by which you can forward me these emails or just put me in cc when some AgiloForScrum things are popping up?

Ok, I'll CC you, but I think we should rather reactivate #5516 ;-)

The idea in the patches there was that you could directly get the semi-automated bug reports in a Trac corresponding to the faulty plugin, or failing that, at least give proper mail contact and avoid semi-automated bug reports to be created on t.e.o's Trac.

The formatting… can be a problem, but I'll have a look in the Agilo code for redirecting, the problem is that if there are other plugins… than it will be unpredictable to which repository it will end.

Maybe even simpler: I don't know if you're re-packaging Trac itself, pristine distribution or with some patches - if so, you could modify the URL for the semi-automated bug report so that it goes to one of yours instead of t.e.o.

No Agilo is a pure and simple plugin (we do runtime patching ;-)) I didn't new there is an easy way to change this, I'll have a look how that can be done.

For now I did it manually, it is now here: https://dev.agile42.com/ticket/846

Thanks and sorry for the traffic ;-) ANdreaT

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.