Edgewall Software
Modify

Opened 8 years ago

Closed 8 years ago

#8465 closed defect (duplicate)

Subversion authorization for Browser Source

Reported by: KlauX Owned by:
Priority: normal Milestone:
Component: version control/browser Version: devel
Severity: normal Keywords: multirepos
Cc: klaux1@…
Release Notes:
API Changes:

Description

The [Browser Source] don't respects the authz_file of [trac] policy.

I'm testing the Trac 0.12multirepos-r8299 version.

Very thanks.

Attachments (0)

Change History (4)

comment:1 Changed 8 years ago by ebray

Could you be more specific?

comment:2 in reply to:  1 Changed 8 years ago by anonymous

Replying to ebray:

Could you be more specific?

Ok! I installed the Trac 0.12multirepos-r8299, informed the authorization file, as on Trac 0.11, and set three repositories. Still, the policies have not worked.

  • /var/lib/trac/environments/ref/conf/trac.ini
[trac]
authz_file = /var/lib/trac/environments/ref/conf/authz
...

[repositories]
ref.dir = /var/lib/svn/repositories/ref
ref.type = svn
ref1.dir = /var/lib/svn/repositories/ref1
ref1.type = svn
ref2.dir = /var/lib/svn/repositories/ref2
ref2.type = svn
...
  • /var/lib/trac/environments/ref/conf/authz
    [groups]
    ref = foo, bar
    
    [ref:/]
    @ref = rw
    
    [/]
    * =
    

comment:3 Changed 8 years ago by KlauX

Even so, access to the three repositories is anonymous.

Excuse me for English, I am still studying this language.

Very Thanks,


KlauX

comment:4 Changed 8 years ago by Christian Boos

Milestone: 0.12
Resolution: duplicate
Status: newclosed

Duplicate of #7116.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .

 
Note: See TracTickets for help on using tickets.