Edgewall Software
Modify

Opened 13 years ago

Closed 13 years ago

#8308 closed defect (duplicate)

Attachments not have stopped working after upgrade

Reported by: jamescw@… Owned by:
Priority: normal Milestone:
Component: attachment Version: 0.11.1
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

I have just upgraded to 0.11.1 using apt.

Everything is working perfectly except for attachments. When a user clicks "Add attachment" after browsing for the file using the file input dialog, the file is does not appear in "Attachments" box on the next page. The file is also not in the <ProjectName>/attachments directory in the trac environment. I have verified the POST is created properly using the correct base URL using Firebug.

Debug log:

2009-05-20 09:49:06,561 Trac[main] DEBUG: Dispatching <Request "GET u'/attachment/wiki/ClassDB/'"> 2009-05-20 09:49:06,586 Trac[svn_fs] DEBUG: Subversion bindings imported 2009-05-20 09:49:06,589 Trac[api] DEBUG: action controllers for ticket workflow: ConfigurableTicketWorkflow 2009-05-20 09:49:06,589 Trac[chrome] DEBUG: Prepare chrome data for request 2009-05-20 09:49:06,643 Trac[session] DEBUG: Retrieving session for ID u'jamescw' 2009-05-20 09:49:06,922 Trac[main] DEBUG: 1687 unreachable objects found. 2009-05-20 09:49:14,977 Trac[main] DEBUG: Dispatching <Request "POST u'/attachment/wiki/ClassDB/'"> 2009-05-20 09:49:14,992 Trac[chrome] DEBUG: Prepare chrome data for request 2009-05-20 09:49:15,001 Trac[session] DEBUG: Retrieving session for ID u'jamescw' 2009-05-20 09:49:15,041 Trac[main] DEBUG: 467 unreachable objects found.

Attachments (0)

Change History (5)

comment:1 by Christian Boos, 13 years ago

If you're using Python 2.6, then it must be a duplicate of #7876. Please upgrade to at least 0.11.3.

comment:2 by anonymous, 13 years ago

Resolution: fixed
Status: newclosed

Thank you. The problem was indeed a duplicate of #7076. upgrading to the latest stable build fixed this issue.

comment:3 by anonymous, 13 years ago

Sorry correct old ticket is: #7076

comment:4 by Christian Boos, 13 years ago

Resolution: fixed
Status: closedreopened

(fixing resolution)

comment:5 by Christian Boos, 13 years ago

Resolution: duplicate
Status: reopenedclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.