Edgewall Software
Modify

Opened 11 years ago

Closed 8 years ago

Last modified 5 years ago

#8293 closed defect (worksforme)

Reporter not Receiving Email notifications Until modifies own ticket

Reported by: dfleming@… Owned by: Emmanuel Blot
Priority: highest Milestone:
Component: notification Version: 0.11.7
Severity: blocker Keywords:
Cc: sheuchler@…, a.rublev@…, chdillon@… Branch:
Release Notes:
API Changes:

Description

I've done some extensive testing on this and it seems with always notify owner / reporter / updater turned on and the notification system otherwise working properly, the reporter receives no notification emails until they go back to the ticket they created and add or change something in the ticket. Then they start receiving notifications. I'm not getting any errors regarding smtp or anything. This is a bit strange. Is anybody else having this problem?

System Information
Trac: 	0.11.3
Python: 	2.4.4 (#1, Oct 22 2008, 19:49:52) [GCC 4.1.2 20061115 (prerelease) (Debian 4.1.1-21)]
setuptools: 	0.6c9
SQLite: 	3.3.8
pysqlite: 	2.3.2
Genshi: 	0.5
mod_python: 	3.2.10
Subversion: 	1.4.2 (r22196)
jQuery:	1.2.6

Attachments (0)

Change History (24)

comment:1 by anonymous, 11 years ago

I am having this problem as well. All my tickets are created with email2trac though. The person who reported the ticket gets no notification what so ever.

comment:2 by David Fleming <dfleming@…>, 11 years ago

Priority: highhighest
Severity: criticalblocker

Anybody Know anything about this?????

comment:3 by Christian Boos, 11 years ago

Keywords: needinfo added

Please first try to reproduce the issue without email2trac or any other plugin being involved, so that you're sure it's an issue with Trac itself.

In the latter case, please provide all the information needed to reproduce the issue, i.e. the relevant settings from TracIni [notification] section (feel free to obfuscate what needs to be).

comment:4 by David Fleming <dfleming@…>, 11 years ago

Version: 0.11.30.11.4

I turned every plugin off and tested. Still doesn't send the reporter a notification until they make a comment or change a field in the ticket. *(this is when they become the updater). All other tests of notification system are successful. Updater, owner, etc…

System Information
Trac: 	0.11.4
Python: 	2.4.4 (#1, Oct 22 2008, 19:49:52) [GCC 4.1.2 20061115 (prerelease) (Debian 4.1.1-21)]
setuptools: 	0.6c9
SQLite: 	3.3.8
pysqlite: 	2.3.2
Genshi: 	0.5
mod_python: 	3.2.10
Subversion: 	1.4.2 (r22196)
jQuery:	1.2.6
[notification]
admit_domains =
always_notify_owner = true
always_notify_reporter = true
always_notify_updater = true
ignore_domains =
mime_encoding = base64
smtp_always_bcc =
smtp_always_cc =
smtp_default_domain =
smtp_enabled = true
smtp_from = trac.*****@*****.com
smtp_from_name = Pluginstestingproject
smtp_password =
smtp_port = 25
smtp_replyto = ****@*****.com
smtp_server = ***.*.*.***
smtp_subject_prefix = __default__
smtp_user =
ticket_subject_template = $prefix #$ticket.id: $summary
use_public_cc = False
use_short_addr = false
use_tls = false

comment:5 by anonymous, 11 years ago

Keywords: Need to recheck added; needinfo removed
Milestone: 0.11.5
Summary: Reporter not Receiving Email notifications Until modifies own tickettotal change

hai some probs here

comment:6 by Remy Blank, 11 years ago

Keywords: needinfo added; Need to recheck removed
Milestone: 0.11.5
Summary: total changeReporter not Receiving Email notifications Until modifies own ticket

This is not a test system. Thank you.

comment:7 by Sebastian Heuchler <sheuchler@…>, 11 years ago

Cc: sheuchler@… added

comment:8 by a.rublev@…, 11 years ago

Cc: a.rublev@… added

comment:9 by anonymous, 11 years ago

Whats this?

comment:10 by anonymous, 11 years ago

Resolution: fixed
Status: newclosed

comment:11 by anonymous, 11 years ago

Resolution: fixed
Status: closedreopened

comment:12 by David Fleming <dfleming@…>, 11 years ago

Is there any news on that status of this fix. It's rather important, more so than most of the other bug fixes. Am I wrong?

comment:13 by Sebastian Krysmanski <sebastian@…>, 11 years ago

Cc: sebastian@… added

Hmmm… this works without problems for me.

Trac:           0.11.4
Python:         2.6.2 (release26-maint, Apr 19 2009, 02:11:59) [GCC 4.3.3]
setuptools:     0.6c9
SQLite:         3.6.10
pysqlite:       2.5.0
Genshi:         0.5.1
Pygments:       1.0
Subversion:     1.6.3 (r38063)
jQuery:         1.2.6

comment:14 by anonymous, 11 years ago

Status

comment:15 by anonymous, 10 years ago

Version: 0.11.40.11.5

Still having an issue with this. Does anybody have any ideas. I'll take any ideas at this point.

comment:16 by anblasko@…, 10 years ago

I'm also having same problem with Trac 0.11.3 or 0.11.5.

INFO: Sending SMTP notification to smtp.gmail.com:587 to [u'ante@…', u'xxx.xxxxx@…']

Where .hr account is reporter and .com account is owner. Reporter never gets mails. Owner does.

[notification]
always_notify_owner = true
always_notify_reporter = true
...

comment:17 by dfleming@…, 10 years ago

Not sure if this will help anyone but I originally created this ticket and We recently moved our trac/subversion environment to a brand new machine with a different OS (from debian to Cent-os(redhat)). Or more precisely, we installed Trac 0.11.3 and upgrade to 0.11.5 then moved all projects over to the new machine. We reinstalled all plugins (because a different version of python among other things) on the new os. We used the same configurations and everything from the old machine. And of course as soon as we moved over this problem in this ticket suddenly stopped. So We don't know if it was a problem with the os or the install of trac or maybe even old version of a plugin but this might help somebody who really wants to get this problem solved. Good luck!

in reply to:  17 comment:18 by Christian Boos, 10 years ago

Keywords: needinfo removed
Resolution: worksforme
Status: reopenedclosed

Replying to dfleming@…:

… So We don't know if it was a problem with the os or the install of trac or maybe even old version of a plugin but this might help somebody who really wants to get this problem solved.

Thank you for letting us know you solved the issue. It seems it was an InstallationIssue after all.

comment:19 by chdillon@…, 10 years ago

Cc: chdillon@… added

I'm having this same issue on a fairly new(about a week old) but very well accepted installation of Trac. I've done some tracing and have narrowed down the area that is having trouble, but i'm not a python dev so i'm a bit confused. The get_recipients method of the TicketNotifyEmail class isn't allways called. It looks like it might only be called maybe the first time a ticket is edited?

I have logging statements in both Notify.notify and TicketNotifyEmail.get_recipients. In cases where the log statements in get_recipients are called, the return is correct and includes the reporter. Subsequent changes and calls to Notify.notify are still getting a list of recipients, but that list 1) does not include the owner, and 2) doesnt seem to come from TicketNotifyEmail since in those cases, my log statements aren't hit.

My users love Trac, but i need to work this out if anyone is interested in helping take a look, or suggesting somewhere else i should look, i would GREATLY appreciate it. I'm not sure where the second implementation of get_recipients is coming from.

    def notify(self, resid):
        self.env.log.debug("cad:Notify.notify")
        (torcpts, ccrcpts) = self.get_recipients(resid)
        self.env.log.debug("cad:Notify.notify after get_recipients %s : %s" % (torcpts, ccrcpts))
        self.begin_send()
        self.send(torcpts, ccrcpts)
        self.finish_send()
    def get_recipients(self, tktid):
        self.env.log.debug("get_recipients for: %s" % (tktid))
        notify_reporter = self.config.getbool('notification',
                                              'always_notify_reporter')
        notify_owner = self.config.getbool('notification',
                                           'always_notify_owner')
        notify_updater = self.config.getbool('notification', 
                                             'always_notify_updater')

        ccrecipients = self.prev_cc
....

comment:20 by anonymous, 10 years ago

Version: 0.11.50.11.7

comment:21 by fai@…, 8 years ago

I've been having this same problem (always_notify_* = true) with reporters not receiving notifications. I've recently upgraded to 12.2, and this issue is still persisting. The trac installation is as vanilla as it gets (no other plugins), running on Centos.

I have myself CC'ed on smtp_always_cc so I receive every new and updated ticket notification, but the users report not receiving any emails.

Has there been any resolution or progress on this?

comment:22 by anonymous, 8 years ago

Resolution: worksforme
Status: closedreopened

(still an issue)

comment:23 by Remy Blank, 8 years ago

Resolution: worksforme
Status: reopenedclosed

This issue seems to have been an installation issue.

Can you please open a new ticket and describe the symptoms you observe precisely, preferably with steps to reproduce the issue? Reopening a two year old ticket makes it difficult to track. You can reference this ticket if you think it's related.

comment:24 by Sebastian Krysmanski <sebastian@…>, 5 years ago

Cc: sebastian@… removed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Emmanuel Blot.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Emmanuel Blot to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.