Edgewall Software
Modify

Opened 10 years ago

Closed 2 years ago

Last modified 2 years ago

#8239 closed defect (duplicate)

TicketNotificationSystem assigns reserved SQL keyword 'new' to ticket attributes.

Reported by: alexs@… Owned by:
Priority: normal Milestone:
Component: notification Version: none
Severity: major Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description (last modified by Peter Suter)

In some circumstances this leads to

ProgrammingError: syntax error at or near "new" at character 19

https://trac.edgewall.org/browser/trunk/trac/ticket/notification.py?rev=7890#L136

Does it even use this parameter anywhere?

I believe this occurs when ticket.save_changes is called *after* TicketNotifyEmail.notify. This doesn't happen anywhere within Trac normally but can lead to problems when writing plugins.

Attachments (0)

Change History (6)

comment:1 by alexs@…, 10 years ago

I'm trying to figure out a fix to this. The simplest method seems to be just copying the entire ticket object before TicketNotifyEmail starts modifying it, this seems a bit untidy to me though.

Last edited 2 years ago by Ryan J Ollos (previous) (diff)

comment:2 by Christian Boos, 10 years ago

Component: ticket systemnotification
Milestone: 0.11.6
Owner: set to Emmanuel Blot

Proposed fix seems OK. Ideally, you could contribute a patch!

comment:3 by Ryan J Ollos, 5 years ago

Milestone: next-minor-0.12.xnext-stable-1.0.x

comment:4 by Ryan J Ollos, 4 years ago

Owner: Emmanuel Blot removed

comment:5 by Ryan J Ollos, 3 years ago

Milestone: next-stable-1.0.xnext-stable-1.2.x

Moved ticket assigned to next-stable-1.0.x since maintenance of 1.0.x is coming to a close. Please move the ticket back if it's critical to fix on 1.0.x.

comment:6 by Peter Suter, 2 years ago

Description: modified (diff)
Milestone: next-stable-1.2.x
Resolution: duplicate
Status: newclosed

Duplicate of #8620.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.