Edgewall Software
Modify

Opened 9 years ago

Closed 9 years ago

#8153 closed defect (fixed)

Website Broke

Reported by: anonymous Owned by: Remy Blank
Priority: highest Milestone: 0.11.4
Component: web frontend Version: 0.11-stable
Severity: normal Keywords:
Cc:
Release Notes:
API Changes:

Description

  1. Visit http://trac.edgewall.org/
  2. Click on "New Ticket"

Here I get a DNS error because the URL it tries to go to is

http://wiki/NewTicket

which does not resolve on my system. To file this bug report I had to manually edit my address bar's URL to append "wiki/NewTicket" to the protocol/hostname "http://trac.edgewall.org/".

It looks to me like a simple broken URL.

Commentary: This is the website for Trac and the button to file a new bug report is broken? WTF? LAME! YOU SUCK!

I'll forgive you but only if you improve Trac's GUI to be as pretty as Redmine's.

Attachments (1)

8153-mainnav-fix-r7956.patch (1.1 KB ) - added by Remy Blank 9 years ago.
Patch fixing both issues.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 9 years ago by Remy Blank

Keywords: omg wtf lame removed

While I don't like your tone, you do have a valid point: the [mainnav] section of TracIni seems to be broken. I wonder if this is related to [7930]?

In the future, please formulate your bug reports in a more neutral tone. Thanks.

comment:2 Changed 9 years ago by Remy Blank

It was indeed [7930], and it also broke redirection of URLs with trailing slashes (e.g. /newticket/ to /newticket, it currently redirects to //newticket instead).

Patch coming up shortly.

Changed 9 years ago by Remy Blank

Patch fixing both issues.

comment:3 Changed 9 years ago by Remy Blank

Owner: set to Remy Blank

The patch above fixes both the mainnav and redirect issue.

The cause is that [7930] changed the behavior of href objects when called with no argument:

href() == href('/') == ''   ->   href() == href('/') == '/'

I'd say this regression is serious enough to be a release blocker, so I suggest we apply the patch and make a second release candidate.

comment:4 Changed 9 years ago by Simon <saimen54@…>

Obviously you have found the problem, but here (Trac 0.11.4rc1, tracd, WinXP) "new Ticket" works without any problems.

comment:5 Changed 9 years ago by Remy Blank

The default navigation items work. But if you define a custom link for a mainnav item in trac.ini, like so:

[mainnav]
newticket.href = /wiki/NewTicket

as is done here on t.e.o, the link is broken.

comment:6 Changed 9 years ago by Remy Blank

Resolution: fixed
Status: newclosed
Version: 0.12dev0.11-stable

Fixed in [7988].

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Remy Blank.
The resolution will be deleted.
to The owner will be changed from Remy Blank to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .

 
Note: See TracTickets for help on using tickets.