Edgewall Software
Modify

Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#8134 closed defect (duplicate)

IntegrityError: columns type, name are not unique

Reported by: canh_nh Owned by: canh_nh
Priority: low Milestone:
Component: general Version: 0.11.2.1
Severity: major Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description

How to Reproduce

While doing a POST operation on /admin/ticket/priority/blocker, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'__FORM_TOKEN': u'e943683d6623bea0d1f13d0d',
 'cat_id': u'ticket',
 'name': u'Crash',
 'panel_id': u'priority',
 'path_info': u'blocker',
 'save': u'Save'}

User Agent was: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.7) Gecko/2009021910 Firefox/3.0.7

System Information

Trac 0.11.2.1
Python 2.4.3 (#1, May 24 2008, 13:47:28)
[GCC 4.1.2 20070626 (Red Hat 4.1.2-14)]
setuptools 0.6c9
SQLite 3.3.6
pysqlite 1.1.7
Genshi 0.5.1
mod_python 3.2.8
jQuery: 1.2.6

Python Traceback

Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/Trac-0.11.2.1-py2.4.egg/trac/web/main.py", line 432, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.4/site-packages/Trac-0.11.2.1-py2.4.egg/trac/web/main.py", line 204, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/lib/python2.4/site-packages/Trac-0.11.2.1-py2.4.egg/trac/admin/web_ui.py", line 113, in process_request
    path_info)
  File "/usr/lib/python2.4/site-packages/Trac-0.11.2.1-py2.4.egg/trac/ticket/admin.py", line 43, in render_admin_panel
    return self._render_admin_panel(req, cat, page, version)
  File "/usr/lib/python2.4/site-packages/Trac-0.11.2.1-py2.4.egg/trac/ticket/admin.py", line 332, in _render_admin_panel
    enum.update()
  File "/usr/lib/python2.4/site-packages/Trac-0.11.2.1-py2.4.egg/trac/ticket/model.py", line 453, in update
    (self.name, self.value, self.type, self._old_name))
  File "/usr/lib/python2.4/site-packages/Trac-0.11.2.1-py2.4.egg/trac/db/util.py", line 50, in execute
    return self.cursor.execute(sql_escape_percent(sql), args)
  File "/usr/lib/python2.4/site-packages/sqlite/main.py", line 255, in execute
    self.rs = self.con.db.execute(SQL % parms)
IntegrityError: columns type, name are not unique

Attachments (0)

Change History (2)

comment:1 by Christian Boos, 11 years ago

Milestone: 0.12
Resolution: duplicate
Status: newclosed

Duplicate of #6348

comment:2 by Christian Boos, 11 years ago

Cc: 123 removed
Component: notificationgeneral
Keywords: 123 removed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain canh_nh.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from canh_nh to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.