Edgewall Software
Modify

Opened 15 years ago

Closed 13 years ago

#811 closed defect (duplicate)

Enscript Fails on Win XP

Reported by: centgraf@… Owned by: Jonas Borgström
Priority: normal Milestone:
Component: version control/browser Version: 0.9b2
Severity: major Keywords: highlighting
Cc: d.mills@… Branch:
Release Notes:
API Changes:

Description

The Enscript syntax-highlighter appears to be failing on my WinXP install of Trac 0.7.1. This is the error log when attempting to view a Java file in the Browser:

6:44:25 PM Trac[file] DEBUG: Displaying file: Test.java mime-type: text/x-java

6:44:25 PM Trac[enscript] DEBUG: type: text/x-java enscript-suffix: java

6:44:25 PM Trac[mimeview] WARNING: Display failed: [Errno 2] No such file or directory: 'c:
program files
apache group
apache2
cgi-bin
tmpw1ownv'

6:44:25 PM Trac[default] DEBUG: Mimetype: text/x-java filename: Test.java

6:44:25 PM Trac[default] DEBUG: Using default mimeviewer

Each attempt to view a file that should be handled with enscript also produces a stranded file in my cgi-bin directory called "tmpXXXXXX", containing the original (unhighlighted) source text. There is no corresponding tmp file containing the HTML version of the file. Since I can use enscript manually via Command Prompt using parameters stolen from enscript.py, I assume that there is a problem with the "NaivePopen" call used to run enscript via Python. Note also that highlighting via SilverCity works like a charm. (I've tested with XML files.)

Versions in use:

Trac 0.7.1

GNU Enscript 1.6.3

SilverCity 0.9.5

Python 2.3.4

svn 1.1.0

Apache 2.0.50

Windows XP SP1

P.S. I've marked this as "major", since the bug leaks files into the cgi-bin dir, which may be a security hazard.

Attachments (0)

Change History (12)

comment:1 by daniel, 15 years ago

Milestone: 0.9

Need to investigate this.

comment:2 by Matthew Good, 15 years ago

Resolution: worksforme
Status: newclosed

Enscript seems to work for me on Windows XP and 2000. Since there's been no activity to indicate that this is still a problem I'm going to close it.

comment:3 by Matthew Good, 15 years ago

Milestone: 0.9

comment:4 by d.mills@…, 15 years ago

Resolution: worksforme
Status: closedreopened
Version: 0.7.10.8.4

OK, I'm reopening this since I get the same problem, and I'm updating the info (I'm getting this in 8.4) and I'm also noting that Apache gives me the following error:

[Mon Aug 22 16:10:09 2005] [error] [client 192.168.0.85] files
easyphp1-8
cgi-bin
tmppoztep \x82tait inattendu.\n

I think this might be a case of spaces in the filename.

comment:5 by d.mills@…, 15 years ago

Cc: d.mills@… added

Another thing to note: the logs from trac give the following:

16:39:37 Trac[file] DEBUG: Path links: ['ITPDA', 'trunc', 'client', 'install', 'src', 'main', 'Main.java']
16:39:37 Trac[file] DEBUG: Displaying file: Main.java  mime-type: text/x-java
16:39:37 Trac[enscript] DEBUG: type: text/x-java enscript-suffix: java
16:39:37 Trac[mimeview] WARNING: Display failed: [Errno 2] No such file or directory: 'c:\\program files\\easyphp1-8\\cgi-bin\\tmpqs4uzs'
16:39:37 Trac[default] DEBUG: Mimetype: text/x-java   filename: Main.java
16:39:37 Trac[default] DEBUG: Using default mimeviewer

Yet the file created in cgi-bin is called tmpcwhr5c

comment:6 by Matthew Good, 14 years ago

#2231 has been marked as a duplicate of this ticket.

comment:7 by zwetan@…, 14 years ago

Version: 0.8.40.9b2

#2231 may not be a duplicate

look at the new comments in #2233 and #2231

comment:8 by anonymous, 14 years ago

Type: defectenhancement

comment:9 by anonymous, 14 years ago

Type: enhancementdefect

comment:10 by anonymous, 13 years ago

Resolution: worksforme
Status: reopenedclosed

comment:11 by anonymous, 13 years ago

Resolution: worksforme
Status: closedreopened

Fixing erroneous status change(back to reopened)

comment:12 by Christian Boos, 13 years ago

Resolution: duplicate
Status: reopenedclosed

I think this might be a case of spaces in the filename.

This can be solved by enclosing the path to enscript in double quotes, see #1573.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.