Edgewall Software
Modify

Opened 10 years ago

Closed 10 years ago

#8034 closed enhancement (duplicate)

Speed issue when restrict_owner=true

Reported by: olivermn@… Owned by:
Priority: normal Milestone:
Component: ticket system Version: 0.11-stable
Severity: normal Keywords: restrict_owner
Cc: datallah@… Branch:
Release Notes:
API Changes:

Description

I am using Trac-0.11stable_r7825-py2.3.egg.

Historically I have advised our new users to fill in Preferences so that email addresses would be available to all in the ticket pull-downs. That coupled with restrict_owner=true has allowed us manage email addresses and limited typos from those inputting tickets.

However, it has also made our ticket tracking slower and slower as users have been added. Now with about 50 users, opening a ticket can take @55sec (unacceptable). A discovery was made that if you removed table entries from the SQL table, sessions, that performance was greatly improved. Eventually this led to our changing of trac.ini to use restrict_owner=false.

I have searched through the tickets and not found a good match. In #7678 a recommendation was made to turn off restrict_owner but there has been no response in the past 4 months and the issue there was over other inefficencies.

I'm using Trac 0.11stable-r7825 which I think should include #6436 and [7610].

Ideally, I'd like to re-enable restrict_owner to true.


I appreciate your help. The world won't come to an end without this one. But performance always sours folks on a tools use.

Attachments (0)

Change History (5)

comment:1 by Remy Blank, 10 years ago

Milestone: 0.11.4
Version: none0.11-stable

Could you please give us the number of rows in your session and session_attribute tables?

select count(*) from session;
select count(*) from session_attribute;

comment:2 by anonymous, 10 years ago

Here is the output from sql:

sqlite> select count(*) from session;
72
sqlite> select count(*) from session_attribute;
274

comment:3 by datallah@…, 10 years ago

Cc: datallah@… added

If you're not using complicated permissions, you may find that the "UsersWithPermCachingPermissionStore" plugin that we use for the Pidgin trac ([here http://developer.pidgin.im/wiki/LocalTracChanges]) meets your needs.

comment:4 by anonymous, 10 years ago

Our setup still uses fine-grained permissions. I have a duplicate test system which I can try to make the change to just to see how it works for me. Thanks

comment:5 by Christian Boos, 10 years ago

Milestone: 0.11.6
Resolution: duplicate
Status: newclosed

#8212 reported extreme slowdown due to restrict_owner = true:

The setting for restrict_owner in the trac.ini was set to true which caused either opening new tickets or displaying existing tickets to take from 5-25 seconds to display. Setting this vaule to false reduced the display time to ~1 sec for both. (comment 3)

Now there has been a previous attempt to improve the speed of get_users_with_permissions, attempt which failed and has been reverted in r5849 with admittedly inefficient code… This lead me to the original ticket #4245, which was actually reopened.

So I'm now closing this one as duplicate of #4245.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.