Edgewall Software
Modify

Opened 11 years ago

Closed 7 years ago

#7999 closed defect (duplicate)

Allow notification only of other's actions, not my own

Reported by: jidanni@… Owned by: Emmanuel Blot
Priority: lowest Milestone:
Component: notification Version: none
Severity: trivial Keywords:
Cc: jidanni@… Branch:
Release Notes:
API Changes:

Description

Bugzilla knows not to send mail if it is a change I made… http://thread.gmane.org/gmane.comp.version-control.subversion.trac.general/23499

Attachments (0)

Change History (8)

in reply to:  description comment:1 by jidanni@…, 11 years ago

Cc: jidanni@… added

For the record, In SpamAssassin I now use

header __J_TRAC_COMMENT X-Trac-Ticket-URL =~/\#comment/
rawbody __J_TRAC_MY_COMMENT /\+-+\n(Changes|Comment) \(by jidanni\b[^\n]*\):\n/m
meta   J_TRAC_OTHERS __J_TRAC_COMMENT && ! __J_TRAC_MY_COMMENT
score  J_TRAC_OTHERS -7
}}}(i.e., enhanced to deal with "submitter@..." obfuscation.)

comment:2 by jidanni@…, 11 years ago

Component: generalnotification
Owner: set to Emmanuel Blot
Priority: normallowest
Severity: normaltrivial

Indeed, due to subtle variations in trac versions, one needs:

rawbody __J_TRAC_MY_COMMENT /\+-+\n{1,2}(Changes|Comment) ?\(by jidanni\b[^\n]*\):\n/m

At least filtering Debian's is straightforward:

header J_DEBIAN_ACK X-Debian-PR-Message=~/^ack/

Anyway: user testing is always good: http://www.useit.com/alertbox

comment:3 by anonymous, 11 years ago

Summary: Allow notification only of other's actions, not my ownjidanni@jidanni.org

I'm talking about trac.edgewall.com, not trac.*.*.

Yes, I'm tired of having to create accounts too. But at least you should have a cookie to remember my email address.

OK, apparently it gets into the Cc at least, for that bug. But then one sees that one is replying as Mr. Anonymous again.

And then there is the poorly designed "Add/Remove from Cc: <Author field>". You really need to do some http://www.useit.com/alertbox style testing on that…

On a more general note, it seems from you last post that you're looking for a bug tracking system that behaves as Bugzilla does: maybe you should stick with bugzilla.

You forgot: we end users have little choice in what bug system we get to use.

You can customize Trac if various different ways, but you can't ask default Trac installations to behave the exact way you think it's best.

All we end users can customize is login name and password, an with edgewall's own trac, not even that.

Anyways, all this is moot point to modem users which I used to be. They can't stay on line typing as it costs more money. That's why Debian's email based tracker is tops.

in reply to:  3 comment:4 by Emmanuel Blot, 11 years ago

Summary: jidanni@jidanni.orgAllow notification only of other's actions, not my own

Replying to anonymous:

Yes, I'm tired of having to create accounts too. But at least you should have a cookie to remember my email address.

This is a feature Trac supports from the early days: click on Preferences, enter your email address and your name. You don't have to be logged in to do this.

All we end users can customize is login name and password, an with edgewall's own trac, not even that.

Only developers can log in on trac.edgewall.org: regular users cannot create accounts, and do not have login name/password.

They can't stay on line typing as it costs more money.

They simply need to click on "Preferences" once, it's faster than creating an account

comment:5 by jidanni@…, 11 years ago

(The above two replies are for bug #8000. Sorry.)

in reply to:  5 ; comment:6 by Christian Boos, 11 years ago

Milestone: 0.13

Replying to jidanni@…:

(The above two replies are for bug #8000. Sorry.)

#8002 you meant.

As for this ticket itself, I'm pretty sure there is a duplicate, but will leave that for when we consider again all the notification tickets at once.

in reply to:  6 comment:7 by Christian Boos, 11 years ago

Replying to cboos:

Replying to jidanni@…:

(The above two replies are for bug #8000. Sorry.)

#8002 you meant.

Ah no, actually not. You use SpamAssassin to do some filtering …

comment:8 by Peter Suter, 7 years ago

Milestone: next-major-releases
Resolution: duplicate
Status: newclosed

Duplicate of #2247.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Emmanuel Blot.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Emmanuel Blot to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.