Edgewall Software
Modify

Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#7937 closed defect (invalid)

TypeError: argument 2 to map() must support iteration: TracHoursPlugin-0.2.-py2.4.egg

Reported by: richard.allen Owned by:
Priority: normal Milestone:
Component: general Version: 0.11.2
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

How to Reproduce

While doing a GET operation on /roadmap, Trac issued an internal error.

(additional details here)

  • This is after installing revision 5096 of the trachours plugin globally on the site-packages folder.
  • Plugin produces error only after running python setup.py install --prefix=/home/alexander_admin/trac/packages
  • Did run the trac-admin updgrade command successfully after installation

User Agent was: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5

System Information

Trac 0.11.2
Python 2.4.4 (#2, Oct 22 2008, 20:20:22)
[GCC 4.1.2 20061115 (prerelease) (Debian 4.1.1-21)]
setuptools 0.6c9
MySQL server: "5.0.67-log", client: "5.0.32", thread-safe: 1
MySQLdb 1.2.2
Genshi 0.5.1
Pygments 0.11.1
Subversion 1.4.2 (r22196)
jQuery: 1.2.6

Python Traceback

Traceback (most recent call last):
  File "/home/.spiral/alexander_admin/trac/packages/lib/python2.4/site-packages/Trac-0.11.2-py2.4.egg/trac/web/main.py", line 432, in _dispatch_request
    dispatcher.dispatch(req)
  File "/home/.spiral/alexander_admin/trac/packages/lib/python2.4/site-packages/Trac-0.11.2-py2.4.egg/trac/web/main.py", line 226, in dispatch
    data, content_type)
  File "/home/.spiral/alexander_admin/trac/packages/lib/python2.4/site-packages/Trac-0.11.2-py2.4.egg/trac/web/chrome.py", line 694, in render_template
    stream |= self._filter_stream(req, method, filename, stream, data)
  File "build/bdist.linux-x86_64/egg/genshi/core.py", line 128, in __or__
  File "/home/.spiral/alexander_admin/trac/packages/lib/python2.4/site-packages/Trac-0.11.2-py2.4.egg/trac/web/chrome.py", line 781, in inner
    data)
  File "/home/.spiral/alexander_admin/trac/packages/lib/python2.4/site-packages/TracHoursPlugin-0.2.-py2.4.egg/trachours/hours.py", line 244, in filter_stream
    stream = handler(req, stream, data)
  File "/home/.spiral/alexander_admin/trac/packages/lib/python2.4/site-packages/TracHoursPlugin-0.2.-py2.4.egg/trachours/hours.py", line 1054, in filter_roadmap
    totalhours = self.get_total_hours(ticket.id)
  File "/home/.spiral/alexander_admin/trac/packages/lib/python2.4/site-packages/TracHoursPlugin-0.2.-py2.4.egg/trachours/hours.py", line 1010, in get_total_hours
    return sum([hour['seconds_worked'] for hour in self.get_ticket_hours(ticket_id)])
  File "/home/.spiral/alexander_admin/trac/packages/lib/python2.4/site-packages/TracHoursPlugin-0.2.-py2.4.egg/trachours/hours.py", line 989, in get_ticket_hours
    where = "ticket in (%s)" % ",".join(map(str, ticket_id)) #note the lack of args.  This is because there's no way to do a placeholder for a list that I can see.
TypeError: argument 2 to map() must support iteration

Attachments (0)

Change History (2)

comment:1 by Emmanuel Blot, 12 years ago

Resolution: invalid
Status: newclosed

What about the NewTicket#Whentonotcreateatickethere section, especially the one dedicated to plugins?

comment:2 by anonymous, 12 years ago

lol. sorry about that, that was a noob ticket. Thanks =)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.