Edgewall Software
Modify

Opened 11 years ago

Closed 10 years ago

#7919 closed defect (fixed)

Bug with structure view in TitleIndex

Reported by: ivan@… Owned by: Christian Boos
Priority: normal Milestone: 0.12
Component: wiki system Version: 0.11
Severity: normal Keywords: titleindex
Cc: ryano@… Branch:
Release Notes:
API Changes:

Description

In r4232 structured page index was added. In my trac v. 0.11 I've created 3 pages: TestTest, TestThing and Test2.

Here is the screenshot of who it looks on TitleIndex page:

Screenshot that describes the error

For some strange reason, the 3rd level structure is created, but here should be only 2 levels.

Attachments (1)

trac_wiki_error.png (1.7 KB ) - added by ivan@… 11 years ago.
Screenshot that describes the error

Download all attachments as: .zip

Change History (8)

by ivan@…, 11 years ago

Attachment: trac_wiki_error.png added

Screenshot that describes the error

comment:1 by Christian Boos, 11 years ago

Milestone: 0.11.3
Owner: set to Christian Boos
Status: newassigned

I'll look into this.

comment:2 by Christian Boos, 11 years ago

Milestone: 0.11.40.11.5

comment:3 by Christian Boos, 10 years ago

Keywords: titleindex added
Milestone: 0.11.60.12.1

Also verify if this is still happening after #4654.

comment:4 by Ryan Ollos <ryano@…>, 10 years ago

Cc: ryano@… added

comment:5 by Christian Boos, 10 years ago

See also #6063.

comment:6 by Christian Boos, 10 years ago

Reproduced with r8981:

This is due to the bad handling of numbers in page names by the TitleIndex macro.

comment:7 by Christian Boos, 10 years ago

Milestone: next-minor-0.12.x0.12
Resolution: fixed
Status: assignedclosed

Fixed in r8985.

With [[TitleIndex(format=group)]] we now have:

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Christian Boos.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Christian Boos to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.