Edgewall Software
Modify

Opened 13 years ago

Closed 12 years ago

Last modified 11 years ago

#7897 closed defect (worksforme)

"bad request" on login with Firefox 3

Reported by: anonymous Owned by:
Priority: normal Milestone:
Component: general Version: 0.11.4
Severity: normal Keywords: firefox needinfo
Cc: s.federici@… Branch:
Release Notes:
API Changes:
Internal Changes:

Description

From time to time, we have user that connects to the TRAC and report a "bad request" Missing or invalid form token. Do you have cookies enabled?

If they try again, it works. So i think it's not related to their configuration, the error occurs from time to time.

A common point: use of last FF version (3.0.5).

(bug similar to #2438 but for FF)

Attachments (0)

Change History (13)

comment:1 by anonymous, 13 years ago

It could be a FF bug, related to the mechanism of update and "save an quit", when FF detects a new version. The problem occurred just after an update of FF. You get the TRAC login page, though you are connected.

comment:2 by Christian Boos, 13 years ago

Resolution: wontfix
Status: newclosed

Hard to reproduce I guess…

If nevertheless someone can confirm and reproduce this with Trac 0.11.x and up, then please reopen.

comment:3 by Remy Blank, 13 years ago

I can easily reproduce a "Missing or invalid form token" error, but it's a corner case. Using Firefox 3:

  • Install Session Manager and configure it to restore the tabs of the previous session on open.
  • Open a custom query in a tab.
  • Close Firefox.
  • Wait for a day or so.
  • Re-open firefox.
  • On the custom query page that was restored, click on "Update".

Quite often, this leads to the error mentioned above. My guess is that this has something to do with cached pages.

comment:4 by inc, 13 years ago

Resolution: wontfix
Status: closedreopened

we have trac 0.11 and firefox 3.0.8 and this also occurs periodically for us. The log file does not seem to shed any light on it, but it is quite annoying as edits have been lost due to it (i.e. mostly occurs when re-bring up firefox from closed but has once occurred during the middle of a ticket edit!). If anyone every works out what the issue is I would love to hear about it.

Trac:	0.11.3
Python:	2.5.1 (r251:54863, Jun 15 2008, 18:24:51) [GCC 4.3.0 20080428 (Red Hat 4.3.0-8)]
setuptools:	0.6c9
SQLite:	3.5.9
pysqlite:	2.3.3
Genshi:	0.5.1
mod_python:	3.3.1
Subversion:	1.5.2 (r32768)
jQuery:	1.2.6

comment:5 by Remy Blank, 13 years ago

Keywords: needinfo added

What we need here is a way to consistently reproduce the issue (and in a reasonable time, i.e. not what I mentioned in comment:3). If anyone can provide this, please report here.

comment:6 by Christian Boos, 13 years ago

Milestone: 1.0

Valid issue, but hard to reproduce, moving for later.

comment:7 by anonymous, 13 years ago

Version: 0.10.40.11.4

Hmmm and what if i have this error _every time_ i like to login using Fx 3.5 and nover when logging in with epiphany (same gecko inside)? What can i do? Epiphany is ok but i like to use Fx :)

comment:8 by anonymous, 13 years ago

Is there any update on this issue? We are also facing the same problem.

comment:9 by Christian Boos, 12 years ago

Keywords: firefox added
Milestone: 1.0not applicable

Does that still happen with FF 3.6?

comment:10 by Christian Boos, 12 years ago

Milestone: not applicable
Resolution: worksforme
Status: reopenedclosed

No feedback, closing.

comment:11 by Simone <s.federici@…>, 11 years ago

Firefox 3.6.14. Currently we are using Trac 0.12.2rc1. Do you have any suggestion to this issue?

comment:12 by Simone <s.federici@…>, 11 years ago

Cc: s.federici@… added

comment:13 by Christian Boos, 11 years ago

If that Trac is reachable from the internet, we could try to debug it. Please mention the URL if this is the case.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.