Edgewall Software
Modify

Opened 12 years ago

Closed 10 years ago

Last modified 10 years ago

#7847 closed defect (duplicate)

[patch] Objective-C syntax highlighting should be supported by Trac + Pygments

Reported by: trac.edgewall.org@… Owned by:
Priority: normal Milestone:
Component: rendering Version: 0.11.2.1
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

Pygments now includes a lexer for Objective C, so Trac should be able to perform syntax highlighting for that language using Pygments. For reasons that are beyond me, this isn't working (using Pygments 1.0).

Attachments (1)

ObjCHightlighting.diff (1.1 KB ) - added by Aleksei Gorny 11 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 by Christian Boos, 12 years ago

Milestone: 0.12

Not only Objectice-C, but all the supported kinds of sources understood by Pygments should be automatically supported.

by Aleksei Gorny, 11 years ago

Attachment: ObjCHightlighting.diff added

comment:2 by aleksei.gorny@…, 11 years ago

Summary: Objective-C syntax highlighting should be supported by Trac + Pygments[patch] Objective-C syntax highlighting should be supported by Trac + Pygments

A small patch that synchronises the definitions of Objective C mimetype in Trac code and Pygments.

comment:3 by Remy Blank, 11 years ago

Milestone: 0.12next-minor-0.12.x

comment:4 by Paul "TBBle" Hampson <Paul.Hampson@…>, 10 years ago

This can be worked around by adding the following to your [mimeviewer] section of your trac.ini

pygments_modes = text/x-objc:objective-c:7

comment:5 by Thijs Triemstra <lists@…>, 10 years ago

Resolution: duplicate
Status: newclosed

Closing this ticket as duplicate of #5533 for the same reason as #5613 and #8570 for example.

comment:6 by Christian Boos, 10 years ago

Milestone: next-minor-0.12.x

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.