Edgewall Software
Modify

Opened 18 years ago

Closed 18 years ago

#782 closed enhancement (invalid)

preview php files

Reported by: walterjwhite@… Owned by: Jonas Borgström
Priority: normal Milestone:
Component: general Version: 0.7.1
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

preview php scripts in a repository

I run a subversion repository along with webdav on a web development server. The server is used by students to create websites that run html or php scripts. When accessing their files in the repository, php code is not run, only the text is displayed. I have php setup correctly, and it works fine in locations that do not have a subversion repository.

Can there be a feature added that copies the selected file(s) or directories to a temporary web-accessible location that can be viewed through normal http access, and after viewing, it will cleanup, by removing the copied files?

Walter

Attachments (0)

Change History (3)

comment:1 by Matthew Good <matt-good.net>, 18 years ago

Resolution: invalid
Status: newclosed

Well, this doesn't really seem like a Trac issue, since it's relevant to the operation of the Subversion Webdav access, not Trac. However, this is a feature, not a bug, since if Apache tried to render the PHP pages in your repository there would be no way to check out the source code, since attempting to access the page would give you the processed result. Attempting to set up a script that copied the requested file somewhere it would be rendered has a lot of problems since you'd need to know which files it includes as well.

My suggestion would be to set up a Subversion post-commit hook script that would automatically export the latest revision of the repository to a location accessible by your web server.

comment:2 by walterjwhite@…, 18 years ago

Resolution: invalid
Status: closedreopened

Hi,

Would it be possible to include that script and functionality (post-commit hook) into trac? I am not a cgi programmer and wouldn't know where to start.

Thanks, Walter

comment:3 by Christopher Lenz, 18 years ago

Resolution: invalid
Status: reopenedclosed

Please try the mailing list for requests like this.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.