Edgewall Software
Modify

Opened 14 years ago

Closed 14 years ago

#7819 closed defect (duplicate)

Adding a New Admin user

Reported by: anonymous Owned by:
Priority: normal Milestone:
Component: general Version: none
Severity: normal Keywords: needinfo
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description (last modified by Remy Blank)

when adding a new Trac Admin user to an already working system with 10 users. the add function causes the followiing issue:

Python Traceback

Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/trac/web/main.py", line 406, in dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.5/site-packages/trac/web/main.py", line 237, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/lib/python2.5/site-packages/webadmin/web_ui.py", line 119, in process_request
    path_info)
  File "/usr/lib/python2.5/site-packages/webadmin/perm.py", line 45, in process_admin_request
    perm.grant_permission(subject, action)
  File "/usr/lib/python2.5/site-packages/trac/perm.py", line 190, in grant_permission
    self.store.grant_permission(username, action)
  File "/usr/lib/python2.5/site-packages/trac/perm.py", line 143, in grant_permission
    (username, action))
  File "/usr/lib/python2.5/site-packages/trac/db/util.py", line 50, in execute
    return self.cursor.execute(sql_escape_percent(sql), args)
  File "/usr/lib/python2.5/site-packages/trac/db/util.py", line 50, in execute
    return self.cursor.execute(sql_escape_percent(sql), args)
IntegrityError: duplicate key violates unique constraint "permission_pk"

Attachments (0)

Change History (4)

comment:1 by Remy Blank, 14 years ago

Description: modified (diff)

Could you please indicate the Trac version you are using (in the version field), along with some details about your installation (database type and version, any plugins, …).

I suspect this is a plugin problem, judging from the .../site-packages/webadmin/... path.

comment:2 by Christian Boos, 14 years ago

(likely duplicate of #3873)

comment:3 by Remy Blank, 14 years ago

Keywords: needinfo added

comment:4 by Christian Boos, 14 years ago

Resolution: duplicate
Status: newclosed

No feedback, closing as duplicate.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.