Edgewall Software
Modify

Opened 13 years ago

Closed 11 years ago

#7639 closed enhancement (duplicate)

"Create New Ticket" UI should fit on one screen

Reported by: lashchev@… Owned by:
Priority: normal Milestone:
Component: ticket system Version: 0.11.1
Severity: normal Keywords:
Cc: ryano@… Branch:
Release Notes:
API Changes:
Internal Changes:

Description

Since Trac is (successfully) pitching a minimalistic approach to task/bug management - "Create New Ticket" UI should be as simple as possible so it takes seconds for users to create new tickets/tasks.

To achieve this:

  • Fields should take reasonable space (not like "Reporter" taking the whole UI line now)
  • Required and/or typically used fields should be displayed on one-page screen (no scrolling to hit "Submit"/"Preview"). Other fields can be moved into a collapsable panel which is collapsed by default.
  • Admin should be able to say what fields to display in "main" properties form and which ones to move to collapsed "advanced" panel. Custom fields should go to "advanced" panel by default unless otherwise specified during custom field install.
  • Order of displayed fields should be consistent (ideally - configurable)

Attachments (0)

Change History (6)

comment:1 by osimons, 13 years ago

Milestone: 0.11.2

See also #7640, #7641.

comment:2 by osimons, 13 years ago

Component: web frontendticket system

comment:3 by Remy Blank, 13 years ago

Milestone: 2.0

comment:4 by Ryan Ollos <ryano@…>, 12 years ago

Cc: ryano@… added

comment:5 by Christian Boos, 11 years ago

Milestone: 2.0unscheduled

Milestone 2.0 deleted

comment:6 by Christian Boos, 11 years ago

Milestone: unscheduled
Resolution: duplicate
Status: newclosed

"Hiding" fields based on the workflow state (#2464) would also help to have the "new ticket UI fit on one screen". Closing as duplicate of that ticket, since this would be the main change that could reduce the complexity of the new ticket page.

For the order of displayed fields, see #9648.

This ticket could be reopened if someone feels like implementing the "advanced" tab suggestion (please provide a patch, in this case).

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.