Edgewall Software
Modify

Opened 13 years ago

Closed 10 years ago

#7554 closed defect (duplicate)

Cannot create attachement dir (OSError: [Errno 36])

Reported by: alexey.lustin <lustin@…> Owned by:
Priority: normal Milestone:
Component: attachment Version: 0.12dev
Severity: major Keywords:
Cc: lustin@… Branch:
Release Notes:
API Changes:
Internal Changes:

Description (last modified by Christian Boos)

Trac normalize a wiki page name and set it to path where attachement save. if a page name not in English then Trac detect an Internal error

OSError: [Errno 36] File name too long: <atachment_env_path>/<long_not_english_page_name>/
[http://www.hosted-projects.com/trac/TracDemo/Demo/wiki/%D0%9E%D1%87%D0%B5%D0%BD%D1%8C%20%D0%B4%D0%BB%D0%B8%D0%BD%D0%BD%D0%BE%D0%B5%20%D0%B8%D0%BC%D1%8F%20%D1%80%D1%83%D1%81%D1%81%D0%BA%D0%BE%D0%B9%20%D1%81%D1%82%D1%80%D0%B0%D0%BD%D0%B8%D1%86%D1%8B%20%D0%B4%D0%BB%D1%8F%20%D0%BF%D1%80%D0%B8%D0%BC%D0%B5%D1%80%D0%B0%20%D0%BF%D0%BE%20%D0%BA%D0%B0%D1%80%D1%82%D0%BE%D1%87%D0%BA%D0%B5%20%D0%BD%D0%B0%20%D0%B1%D0%B0%D0%B3%20%D1%81%20%D0%B4%D0%BE%D0%B1%D0%B0%D0%B2%D0%BB%D0%B5%D0%BD%D0%B8%D0%B5%D0%BC%20%D0%B0%D1%82%D0%B0%D1%87%D0%BC%D0%B5%D0%BD%D1%82%D0%B0 Example on TracDemo (try to add atachment to the page)]

i think what is defect

May be we need an option on trac.ini something like this

...
[attachement]
normalize_attach_dir = false/true
...

for exaple my OS (Ubuntu 8.04)
Python: 2.5.2 (r252:60911, Jul 31 2008, 17:28:52) [GCC 4.2.3 (Ubuntu 4.2.3-2ubuntu7)]
correctly create catalog with command

mkdir 'Очень длинное русское имя каталога для примера того что не обязательно преобразовывать имя страницы wiki'

PS: In the past on DokuWiki this problem will be issued and fixed

Attachments (0)

Change History (3)

comment:1 by Christian Boos, 12 years ago

Description: modified (diff)
Milestone: 0.121.0
Summary: Cannot create atachement catalog (OSError: [Errno 36])Cannot create attachement dir (OSError: [Errno 36])

I guess you meant directory instead of catalog.

I don't think that we can avoid normalization, there are characters that are valid in WikiPageNames but not in path names (think Windows).

What we could do is to revert to using a hash of the name instead of the (url encoded) name itself, when that name is too long.

This is in some ways related to #7397.

comment:2 by Christian Boos, 12 years ago

Milestone: 1.0unscheduled

Milestone 1.0 deleted

comment:3 by Remy Blank, 10 years ago

Milestone: unscheduled
Resolution: duplicate
Status: newclosed

This is a duplicate of #10313.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.