Edgewall Software
Modify

Opened 13 years ago

Closed 13 years ago

#7351 closed defect (duplicate)

Renaming a milestone to a name that was already given to another milestone results in a stacktrace being printed to the page.

Reported by: marijn.van.der.zee@… Owned by: Jonas Borgström
Priority: normal Milestone:
Component: roadmap Version: 0.11rc1
Severity: minor Keywords: milestone
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

Note that creating a new milestone with an existing name has the desired behavior, namely showing an error message specifying what went wrong.

How to reproduce: In my case, I had two milestones in my project: one named "08w26" and one named "08w30". All fields other than name are left blank. Editing milestone "08w30" and renaming it to "08w26" shows the defect.

System Information: Windows Server 2003, PostgreSQL 8.3, svn

Backtrace

Traceback (most recent call last):
  File "c:\program files\python25\lib\site-packages\trac-0.11rc1-py2.5.egg\trac\web\api.py", line 339, in send_error
    'text/html')
  File "c:\program files\python25\lib\site-packages\trac-0.11rc1-py2.5.egg\trac\web\chrome.py", line 708, in render_template
    if not req.session or not int(req.session.get('accesskeys', 0)):
  File "c:\program files\python25\lib\site-packages\trac-0.11rc1-py2.5.egg\trac\web\api.py", line 168, in __getattr__
    value = self.callbacks[name](self)
  File "c:\program files\python25\lib\site-packages\trac-0.11rc1-py2.5.egg\trac\web\main.py", line 257, in _get_session
    return Session(self.env, req)
  File "c:\program files\python25\lib\site-packages\trac-0.11rc1-py2.5.egg\trac\web\session.py", line 142, in __init__
    self.get_session(req.authname, authenticated=True)
  File "c:\program files\python25\lib\site-packages\trac-0.11rc1-py2.5.egg\trac\web\session.py", line 156, in get_session
    super(Session, self).get_session(sid, authenticated)
  File "c:\program files\python25\lib\site-packages\trac-0.11rc1-py2.5.egg\trac\web\session.py", line 56, in get_session
    (sid, int(authenticated)))
  File "c:\program files\python25\lib\site-packages\trac-0.11rc1-py2.5.egg\trac\db\util.py", line 50, in execute
    return self.cursor.execute(sql_escape_percent(sql), args)
  File "c:\program files\python25\lib\site-packages\trac-0.11rc1-py2.5.egg\trac\db\util.py", line 50, in execute
    return self.cursor.execute(sql_escape_percent(sql), args)
InternalError: current transaction is aborted, commands ignored until end of transaction block

Attachments (0)

Change History (3)

comment:1 by Piotr Kuczynski <piotr.kuczynski@…>, 13 years ago

Component: generalroadmap
Milestone: 0.11.1

comment:2 by Piotr Kuczynski <piotr.kuczynski@…>, 13 years ago

Keywords: milestone added

comment:3 by osimons, 13 years ago

Milestone: 0.11.1
Resolution: duplicate
Status: newclosed

Testing on sqlite, it results in the infamous IntegrityError: column name is not unique.

There are already plenty of duplicates of this issue in various forms and for various tables. The important tickets though seems to be #6808 and #6348. I'm closing this ticket as a duplicate, and will add a note about it at #6348.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.