Edgewall Software
Modify

Opened 11 years ago

Closed 10 years ago

#7334 closed defect (fixed)

tracmercurial problem

Reported by: dolus@… Owned by: Noah Kantrowitz
Priority: normal Milestone: plugin - mercurial
Component: plugin/mercurial Version: 0.11rc2
Severity: normal Keywords: setuptools
Cc: Branch:
Release Notes:
API Changes:

Description (last modified by Emmanuel Blot)

Hello, I've installed trac 0.11rc2 tracmercurial 0.11 (TracMercurial-0.11.0.3-py2.4.egg file is in /usr/lib/python2.4/site-packages) Mercurial version is: 1.0 (i didnt have any problems with 0.10.4 with tracmercurial 0.10) but i cannot browse mercurial repos: I see this warning:

Warning: Can't synchronize with the repository (Unsupported version control system "hg". Check that the Python support libraries for "hg" are correctly installed.)
Here's entry from my trac.log:
2008-06-14 00:06:21,245 Trac[loader] ERROR: Skipping "hg = tracext.hg.backend": (can't import "No module named tracext.hg.backend")

And here's specific lines from my trac.ini

[components]
tracext.hg.* = enabled
[trac]
repository_dir = /home/arch/hgrepos/l10n
repository_type = hg

Attachments (0)

Change History (9)

in reply to:  description ; comment:1 by Emmanuel Blot, 11 years ago

Description: modified (diff)
Keywords: hg added
Version: 0.11rc2

Replying to dolus@eventualis.org:

Hello, I've installed trac 0.11rc2 tracmercurial 0.11 (TracMercurial-0.11.0.3-py2.4.egg file is in /usr/lib/python2.4/site-packages)

Notice the version field in the ticket description: you want to fill in when you file a ticket.

in reply to:  1 comment:2 by Emmanuel Blot, 11 years ago

Replying to eblot:

Notice the version field in the ticket description: you want to fill in when you file a ticket.

hum: fill it … file in; anyway, please use the version field.

comment:3 by dolus@…, 11 years ago

Resolution: fixed
Status: newclosed

sorry for acting like a newbie :(

i've solved my problem. Here's what i have done: i did a svn co to tracmercurial-0.11

python setup.py bdist_egg
then:
easy_install --always-unzip TracMercurial-0.11.0.3-py2.4.egg
echo "__import__('pkg_resources').declare_namespace(__name__)" > /usr/lib/python2.4/site-packages/TracMercurial-0.11.0.3-py2.4.egg/tracext/__init__.py
}}
The problem is, a __init__.py is missing in tracext dir.

comment:4 by Piotr Kuczynski <piotr.kuczynski@…>, 11 years ago

Milestone: 0.11.1

comment:5 by Christian Boos, 11 years ago

Milestone: 0.11.1not applicable
Resolution: fixed
Status: closedreopened

Actually Noah fixed this some days ago.

comment:6 by Christian Boos, 11 years ago

Component: version controlplugin/mercurial
Keywords: setuptools added; hg removed
Owner: changed from Christian Boos to Noah Kantrowitz
Status: reopenednew

comment:7 by Christian Boos, 11 years ago

Resolution: fixed
Status: newclosed

Fixed in [7217:7218].

comment:8 by georgwk@…, 10 years ago

Resolution: fixed
Status: closedreopened

Fixed? Believe it or not I just ran into the same problem, I'm installing from the multirepos branch at 8584, and there was no init.py in my tracext.

Thought you might want to know.

comment:9 by Christian Boos, 10 years ago

Milestone: not applicablemercurial-plugin
Resolution: fixed
Status: reopenedclosed

Just verified again all the 3 versions of the plugin using tracext, the tracext/__init__.{py,pyc} files are in the .egg.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Noah Kantrowitz.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Noah Kantrowitz to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.