Edgewall Software
Modify

Opened 15 years ago

Closed 15 years ago

Last modified 13 years ago

#733 closed defect (fixed)

Words seperated by a slash like Abc/Def are treated as CamelCase word

Reported by: vittorio Owned by: Jonas Borgström
Priority: normal Milestone: 0.9
Component: wiki system Version: devel
Severity: minor Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description

Two ore more words seperated by a slash are treated as a CamelCase word and therefor generate a wikipage link. Examples: Abc/Def, Trac/Subversion, Abc/Def/Ghi

Rule 1 in WikiPageNames says: The name must consist of alphabetic characters only.

using trunk 894

Attachments (0)

Change History (7)

comment:1 by Matthew Good <matt-good.net>, 15 years ago

Yes, I noticed this as well. I suppose one issue to address here is whether Trac should support slashes in WikiPageNames at all, or whether names separated by slashes should be considered separately.

Someone has already created a page TracProject/UiGuidelines which makes use of the slash. MoinMoin uses slashes to allow for heirarchical organization of Wiki pages. If a Wiki name is preceded by a slash it is considered to be relative to the current page. So, on the TracProject page I could simply put /UiGuidelines and it would link to TracProject/UiGuidelines.

If slashes are permitted as part of a page name, what would be the appropriate behavior of NotCamel/Camel ?

comment:2 by utopiste, 15 years ago

Resolution: fixed
Status: newclosed

Updated the documentation about WikiPageNames. (it's a feature not a bug)

comment:3 by Matthew Good <matt-good.net>, 15 years ago

Resolution: fixed
Status: closedreopened

Well, I agree that slashes can be used to create a page heirarchy, but I still feel there's an issue here. Neither Abc nor Def would be considered a page name individually, but when joined with a slash they suddenly are. If slashes are meant to represent a heirarchy the implication is that the part preceding the slash is a page, and the part following the slash is a sub-page. So, I believe that each piece of the page heirarchy should be a proper Wiki page name.

For reference MoinMoin would consider Abc/Def as plain text since no part of it is a page name, NotCamel/Camel would render with the NotCamel part as a link, but the /Camel part would be plain text. Only TracProject/UiGuidelines would be considered in whole as a Wiki page link.

I think this is particularly important with the way they consider /PageName to be a sub-page of whatever the current page is, but even if that is not implemented in Trac, it still seems inconsistent that Abc/Def would seemingly be a link to a page Def under Abc, when Abc would not be considered a Wiki page.

comment:4 by daniel, 15 years ago

Milestone: 0.9

comment:5 by anonymous, 15 years ago

The problem doesnt happen anymore with r954. (accidently corrected?)

comment:6 by vittorio, 15 years ago

Resolution: fixed
Status: reopenedclosed

problem doesnt occur in 0.8 anymore

comment:7 by cboos@…, 15 years ago

Check: TheCurrentBehavior/IsLikeThat

And the WikiPageNames states that:

  1. The use of slash ( / ) is permitted to create a hierarchy inside the wiki.

Now I think everything is clear (at least for me :)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.