Edgewall Software
Modify

Opened 12 years ago

Closed 12 years ago

#7007 closed defect (duplicate)

IntegrityError: duplicate key violates unique constraint "session_pk"

Reported by: anonymous Owned by: Jonas Borgström
Priority: normal Milestone:
Component: general Version:
Severity: normal Keywords: session verify
Cc: Branch:
Release Notes:
API Changes:

Description

How to Reproduce

While doing a GET operation on /report/5, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'id': u'5'}

System Information

Trac 0.11dev-r6683
Python 2.4.3 (#2, Oct 6 2006, 07:49:22)
[GCC 4.0.3 (Ubuntu 4.0.3-1ubuntu5)]
setuptools 0.6c7
psycopg2 2.0.5.1
Genshi 0.5dev-r801
Pygments 0.9
Subversion 1.3.2 (r19776)

Python Traceback

Traceback (most recent call last):
  File "/usr/local/virtualenv/lib/python2.4/site-packages/Trac-0.11dev_r6683-py2.4.egg/trac/web/main.py", line 419, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/local/virtualenv/lib/python2.4/site-packages/Trac-0.11dev_r6683-py2.4.egg/trac/web/main.py", line 221, in dispatch
    req.session.save()
  File "/usr/local/virtualenv/lib/python2.4/site-packages/Trac-0.11dev_r6683-py2.4.egg/trac/web/session.py", line 175, in save
    (self.sid, self.last_visit, authenticated))
  File "/usr/local/virtualenv/lib/python2.4/site-packages/Trac-0.11dev_r6683-py2.4.egg/trac/db/util.py", line 50, in execute
    return self.cursor.execute(sql_escape_percent(sql), args)
  File "/usr/local/virtualenv/lib/python2.4/site-packages/Trac-0.11dev_r6683-py2.4.egg/trac/db/util.py", line 50, in execute
    return self.cursor.execute(sql_escape_percent(sql), args)
IntegrityError: duplicate key violates unique constraint "session_pk"


Attachments (0)

Change History (2)

comment:1 by Christian Boos, 12 years ago

Keywords: session verify added
Milestone: 0.11.1

Right, this happened to me as well on t.e.o. Seems to be a duplicate of #3563.

comment:2 by Christian Boos, 12 years ago

Milestone: 0.11.1
Resolution: duplicate
Status: newclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.