Edgewall Software
Modify

Opened 14 years ago

Closed 14 years ago

#6624 closed defect (duplicate)

Revision applies to directories not involved

Reported by: sylvain@… Owned by: Christian Boos
Priority: normal Milestone:
Component: version control/browser Version: 0.10.3
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

I don't know why but when I commit a file or a folder on my repository Trac browser says that another higher particular folder tree ('aFiles' at the root of the browser) is involved in the last revision but he is not.

Exemple :

http://aforge.abstraction.fr/browser

Trac says "aFiles" is involved in revision 92, but he is not and it's confirmed here :

http://aforge.abstraction.fr/changeset/92

In fact trac browser says that the aFiles folder is always part of the last revision.

I tried to resync trac environement but didn't work.

Regards.

Attachments (0)

Change History (9)

comment:1 by Emmanuel Blot, 14 years ago

Upgrade to release 0.10.4.
0.10.3 is known to have some flaws with version control management.

comment:2 by Noah Kantrowitz, 14 years ago

This is a feature, the rev/log on a folder will show the last change anywhere below that folder.

in reply to:  2 ; comment:3 by Emmanuel Blot, 14 years ago

Replying to nkantrowitz:

This is a feature, the rev/log on a folder will show the last change anywhere below that folder.

AFAICT, that's the point:

[92] shows that /dimdim/trunk/asw has been removed so

  • /dimdim/trunk/asw,
  • /dimdim/trunk,
  • /dimdim,
  • / folders

should be tagged (SVN bubble up). No other directory should be tagged with [92]
However, the browser pointed at / shows that /aFiles (and everything below it) is also tagged with [92]

So either there's a weird project setting, or this is definitely a bug.

comment:4 by sylvain@…, 14 years ago

I don't know if it helps but the trac browser points to a scope into the repository.

Repository : /var/svn Scope : /var/svn/public/aForge

in reply to:  4 comment:5 by Emmanuel Blot, 14 years ago

Replying to sylvain@abstraction.fr:

I don't know if it helps but the trac browser points to a scope into the repository.

Repository : /var/svn Scope : /var/svn/public/aForge

Could you dump the complete changeset log report with the svn tool ?

svn log -v  -r 92 repos_url

comment:6 by sylvain, 14 years ago

wellington:/var/svn# svn log -v -r 92 svn://svn.abstraction.fr/public/aForge
------------------------------------------------------------------------
r92 | Absynthe | 2008-01-09 23:01:00 +0100 (mer, 09 jan 2008) | 1 line
Chemins modifiés :
   D /public/aForge/dimdim/trunk/asw

Removed file/folder
------------------------------------------------------------------------

in reply to:  6 comment:7 by Emmanuel Blot, 14 years ago

Replying to sylvain:

r92 | Absynthe | 2008-01-09 23:01:00 +0100 (mer, 09 jan 2008) | 1 line
    D /public/aForge/dimdim/trunk/asw

I see no reason why /public/aForge/aFiles would have been tagged. Try to upgrade…

in reply to:  3 comment:8 by anonymous, 14 years ago

Replying to eblot:

Replying to nkantrowitz:

This is a feature, the rev/log on a folder will show the last change anywhere below that folder.

AFAICT, that's the point:

Whoops, ignore me then. Scoped repos were one of the things worked on during 0.10, so your original assessment is probably the best starting place. /me hangs head.

comment:9 by Christian Boos, 14 years ago

Resolution: duplicate
Status: newclosed

Duplicate of #3470.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Christian Boos.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Christian Boos to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.