Edgewall Software
Modify

Opened 14 years ago

Closed 14 years ago

#6585 closed defect (duplicate)

create project error (ValueError)

Reported by: mirr187@… Owned by: Christopher Lenz
Priority: normal Milestone:
Component: admin/console Version: 0.10.4
Severity: normal Keywords: trac-admin
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

system: 2.6.21-gentoo

sqlite-2.8.16 sqlite3-3.5.3 trac-0.10.4 svn-1.4.5

encounted problem that…

apocalypse trac # trac-admin test initenv
Creating a new Trac environment at /var/lib/trac/test

Trac will first ask a few questions about your environment
in order to initalize and prepare the project database.

 Please enter the name of your project.
 This name will be used in page titles and descriptions.

Project Name [My Project]>

 Please specify the connection string for the database to use.
 By default, a local SQLite database is created in the environment
 directory. It is also possible to use an already existing
 PostgreSQL database (check the Trac documentation for the exact
 connection string syntax).

Database connection string [sqlite:db/trac.db]>

 Please specify the type of version control system,
 By default, it will be svn.

 If you don't want to use Trac with version control integration,
 choose the default here and don't specify a repository directory.
 in the next question.

Repository type [svn]>

 Please specify the absolute path to the version control
 repository, or leave it blank to use Trac without a repository.
 You can also set the repository location later.

Path to repository [/path/to/repos]>

 Please enter location of Trac page templates.
 Default is the location of the site-wide templates installed with Trac.

Templates directory [/usr/share/trac/templates]>

Creating and Initializing Project
Failed to create environment. database parameter must be string or APSW Connection object
Traceback (most recent call last):
  File "/usr/lib64/python2.5/site-packages/trac/scripts/admin.py", line 613, in do_initenv
    options=options)
  File "/usr/lib64/python2.5/site-packages/trac/env.py", line 145, in __init__
    self.create(options)
  File "/usr/lib64/python2.5/site-packages/trac/env.py", line 250, in create
    DatabaseManager(self).init_db()
  File "/usr/lib64/python2.5/site-packages/trac/db/api.py", line 70, in init_db
    connector.init_db(**args)
  File "/usr/lib64/python2.5/site-packages/trac/db/sqlite_backend.py", line 121, in init_db
    cnx = sqlite.connect(path, timeout=int(params.get('timeout', 10000)))
ValueError: database parameter must be string or APSW Connection object

Attachments (0)

Change History (1)

comment:1 by Christian Boos, 14 years ago

Resolution: duplicate
Status: newclosed

Duplicate of #6396, fixed in r6223 for [miletone:0.11] and ported to 0.10.5dev in r6224.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Christopher Lenz.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Christopher Lenz to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.