Edgewall Software
Modify

Opened 15 years ago

Closed 15 years ago

Last modified 13 years ago

#619 closed defect (fixed)

Ticket close actions invisible unless a comment was added when closing ticket.

Reported by: Jonas Borgström Owned by: Jonas Borgström
Priority: high Milestone: 0.8
Component: timeline Version: 0.7.1
Severity: major Keywords:
Cc: trac@… Branch:
Release Notes:
API Changes:

Description

#494 was closed without a comment and doesn't show up on the timeline.

Attachments (1)

invisible_ticket.patch (916 bytes ) - added by Matthew Good <matt-good.net> 15 years ago.
Test for comment field moved to join instead of where clause

Download all attachments as: .zip

Change History (13)

comment:1 by Jonas Borgström, 15 years ago

Related bugs and checkins #530 and [744].

comment:2 by daniel, 15 years ago

Owner: changed from Jonas Borgström to daniel
Status: newassigned

comment:3 by daniel, 15 years ago

Resolution: fixed
Status: assignedclosed

comment:4 by daniel, 15 years ago

Resolution: fixed
Status: closedreopened

comment:5 by daniel, 15 years ago

Resolution: fixed
Status: reopenedclosed

Works in trunk.

comment:6 by daniel, 15 years ago

Resolution: fixed
Status: closedreopened

comment:7 by daniel, 15 years ago

Resolution: fixed
Status: reopenedclosed

comment:8 by daniel, 15 years ago

Turned out this due to bug in an earlier sqlite version.

from now on we should recommend/depend on SQLite ≥2.8.13

comment:9 by Matthew Good <matt-good.net>, 15 years ago

I'm experiencing this same issue with code from trunk [897] and SQLite 2.8.15

This may actually be a new issue with the same symptoms since it's actually a problem with the query added in [744]

The problem is:

 AND t3.field = 'comment'

Since this is placed in the where clause it won't return any ticket changes where there's no associated comment. If this is moved to the t3 join it works fine.

I'll attach a patch.

by Matthew Good <matt-good.net>, 15 years ago

Attachment: invisible_ticket.patch added

Test for comment field moved to join instead of where clause

comment:10 by Matthew Good <matt-good.net>, 15 years ago

Cc: trac@… added
Resolution: fixed
Status: closedreopened

Oops, I guess I forgot to reopen this before.

comment:11 by Jonas Borgström, 15 years ago

Owner: changed from daniel to Jonas Borgström
Status: reopenednew

comment:12 by Jonas Borgström, 15 years ago

Resolution: fixed
Status: newclosed

Applied in [922], thanks!

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.