Edgewall Software
Modify

Opened 15 years ago

Closed 15 years ago

#595 closed defect (worksforme)

failure on http://projects.edgewall.com/trac/wiki/TracFaq

Reported by: anonymous Owned by: Jonas Borgström
Priority: normal Milestone:
Component: wiki system Version:
Severity: major Keywords: rst faq
Cc: Branch:
Release Notes:
API Changes:

Description

2 minutes ago, tried 2x: ============= Oops…

Trac detected an internal error:

1

If you think this really should work and you can reproduce it. Then you should consider to report this problem to the Trac team.

Go to http://trac.edgewall.com/ and create a new ticket where you describe the problem, how to reproduce it and don't forget to include the python traceback found below.

TracGuide — The Trac User and Administration Guide Python traceback

Traceback (most recent call last):

File "/usr/lib/python2.2/site-packages/trac/ModPythonHandler.py", line 184, in handler

core.dispatch_request(mpr.path_info, args, mpr, env)

File "/usr/lib/python2.2/site-packages/trac/core.py", line 410, in dispatch_request

module.run()

File "/usr/lib/python2.2/site-packages/trac/Module.py", line 45, in run

self.render()

File "/usr/lib/python2.2/site-packages/trac/Wiki.py", line 285, in render

Formatter(self.req.hdf, self.env).format(self.page.text, out)

File "/usr/lib/python2.2/site-packages/trac/WikiFormatter.py", line 479, in format

self.handle_code_block(line)

File "/usr/lib/python2.2/site-packages/trac/WikiFormatter.py", line 440, in handle_code_block

self.out.write(self.code_processor(self.hdf, self.code_text, self.env))

File "/usr/lib/python2.2/site-packages/trac/wikimacros/rst.py", line 142, in execute

html = publish_string(text, writer_name = 'html', parser = _parser, enable_exit=0)

File "/usr/lib/python2.2/site-packages/docutils/core.py", line 378, in publish_string

return pub.publish(enable_exit=enable_exit)

File "/usr/lib/python2.2/site-packages/docutils/core.py", line 221, in publish

sys.exit(1)

SystemExit: 1

Attachments (0)

Change History (1)

comment:1 by daniel, 15 years ago

Keywords: rst faq added
Resolution: worksforme
Status: newclosed

I believe this was due to a bug in the modpython code that jborg fixed(?). Closing it for now.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.