Edgewall Software
Modify

Opened 13 years ago

Closed 10 years ago

#5483 closed defect (worksforme)

IE related formatting bug in Trac markup system

Reported by: mgoettsche@… Owned by: Jonas Borgström
Priority: normal Milestone:
Component: ticket system Version: 0.10-stable
Severity: minor Keywords: iexplorer css
Cc: Branch:
Release Notes:
API Changes:

Description (last modified by Emmanuel Blot)

Good day,

there appears to be a formatting bug related to Internet Explorer in Trac's markup system when using {{{...}}}.

  • Example 1 (trac_opera.png, how it looks like in Opera)
  • Example 2 (trac_IE.png, how it looks in IE7)
  • Example 3 (trac_IE2.png, IE7, different bug)

Two problems:

  1. The text in the preformatted boxes is not readable in Internet Explorer 7.
  2. The general use of scroll areas for text longer than the comment box width. I understand that this is the desired behavior, but it would be great if one could disable the scrolling functionality with an extra option

Thanks in advance!

Attachments (4)

trac_opera.png (5.4 KB ) - added by anonymous 13 years ago.
trac_IE.png (7.1 KB ) - added by anonymous 13 years ago.
trac_IE2.png (166.8 KB ) - added by anonymous 13 years ago.
trac_comparison.gif (28.6 KB ) - added by jason@… 12 years ago.
Comparison sample of FF2.0, IE7, and IE6

Download all attachments as: .zip

Change History (11)

by anonymous, 13 years ago

Attachment: trac_opera.png added

by anonymous, 13 years ago

Attachment: trac_IE.png added

by anonymous, 13 years ago

Attachment: trac_IE2.png added

comment:1 by Emmanuel Blot, 12 years ago

Description: modified (diff)

(improving description formatting)

Which version of Trac did you use to reproduce this error?

comment:2 by Christian Boos, 12 years ago

test

test
test
test
test test testtest test testtest test testtest test testtest test test

comment:3 by Christian Boos, 12 years ago

Keywords: css added
Milestone: 0.10.5
Severity: normalminor
Version: 0.10-stable

Right, same behavior here with IE7 (works fine with Firefox though).

by jason@…, 12 years ago

Attachment: trac_comparison.gif added

Comparison sample of FF2.0, IE7, and IE6

comment:4 by Christian Boos, 11 years ago

Keywords: iexplorer added
Milestone: 0.10.60.11.6

#8158 closed as duplicate of this ticket.

Moving up the milestone, though I still have no idea what we can do here. Maybe a min-height rule for IE only?

comment:5 by Christian Boos, 10 years ago

By the way, this problem is gone in IE8.

worksforme?

in reply to:  5 comment:6 by Remy Blank, 10 years ago

Replying to cboos:

worksforme?

+1 from me, but I'm biased (not using IE at all).

comment:7 by Christian Boos, 10 years ago

Milestone: 0.12.1
Resolution: worksforme
Status: newclosed

Ok, people using IE7 should upgrade to IE8, it's quite nicer ;-)

If someone is sufficiently annoyed by this issue on IE7 and motivated to write a patch that doesn't break anything else (especially for other browsers), feel free to reopen and submit it.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.