Edgewall Software
Modify

Opened 15 years ago

Closed 15 years ago

Last modified 13 years ago

#547 closed defect (duplicate)

get_recipients now takes a ticket ID, not a ticket

Reported by: trac@… Owned by: Jonas Borgström
Priority: normal Milestone:
Component: ticket system Version: devel
Severity: major Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description

Email notification is broken without this patch.

Traceback (most recent call last):
  File "/System/Library/Frameworks/Python.framework/Versions/2.3/lib/python2.3/site-packages/trac/ModPythonHandler.py", line 172, in handler
    core.dispatch_request(mpr.path_info, args, mpr, env)
  File "/System/Library/Frameworks/Python.framework/Versions/2.3/lib/python2.3/site-packages/trac/core.py", line 403, in dispatch_request
    module.run()
  File "/System/Library/Frameworks/Python.framework/Versions/2.3/lib/python2.3/site-packages/trac/Module.py", line 45, in run
    self.render()
  File "/System/Library/Frameworks/Python.framework/Versions/2.3/lib/python2.3/site-packages/trac/Ticket.py", line 387, in render
    self.save_changes (id)
  File "/System/Library/Frameworks/Python.framework/Versions/2.3/lib/python2.3/site-packages/trac/Ticket.py", line 322, in save_changes
    tn.notify(ticket, newticket=0, modtime=time.time())
  File "/System/Library/Frameworks/Python.framework/Versions/2.3/lib/python2.3/site-packages/trac/Notify.py", line 223, in notify
    NotifyEmail.notify(self, ticket['id'], subject)
  File "/System/Library/Frameworks/Python.framework/Versions/2.3/lib/python2.3/site-packages/trac/Notify.py", line 127, in notify
    Notify.notify(self, resid)
  File "/System/Library/Frameworks/Python.framework/Versions/2.3/lib/python2.3/site-packages/trac/Notify.py", line 74, in notify
    rcpts = self.get_recipients(resid)
  File "/System/Library/Frameworks/Python.framework/Versions/2.3/lib/python2.3/site-packages/trac/Notify.py", line 270, in get_recipients
    cursor.execute('SELECT reporter,cc FROM ticket WHERE id=%s', ticket['id'])
TypeError: string indices must be integers

Attachments (1)

recipients.patch (1.1 KB ) - added by trac@… 15 years ago.
Fix get_recipients to take a ticket ID

Download all attachments as: .zip

Change History (2)

by trac@…, 15 years ago

Attachment: recipients.patch added

Fix get_recipients to take a ticket ID

comment:1 by trac@…, 15 years ago

Resolution: duplicate
Status: newclosed

Oops, this is a duplicate of #544.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.