Edgewall Software
Modify

Opened 14 years ago

Closed 14 years ago

#5445 closed defect (duplicate)

SQL logic error or missing database when adding milestone with existing name

Reported by: zregvart@… Owned by: Jonas Borgström
Priority: low Milestone:
Component: general Version: 0.10.3
Severity: minor Keywords: SQL logic error milestone existing name
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

If you try to create a milestone that has the same name as an existing (in my case closed milestone), SQL logic error arises:

Traceback (most recent call last):
  File "/usr/local/lib/python2.4/site-packages/trac/web/main.py", line 387, in dispatch_request
    dispatcher.dispatch(req)
  File "/usr/local/lib/python2.4/site-packages/trac/web/main.py", line 237, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/local/lib/python2.4/site-packages/trac/ticket/roadmap.py", line 359, in process_request
    self._do_save(req, db, milestone)
  File "/usr/local/lib/python2.4/site-packages/trac/ticket/roadmap.py", line 430, in _do_save
    milestone.insert()
  File "/usr/local/lib/python2.4/site-packages/trac/ticket/model.py", line 616, in insert
    (self.name, self.due, self.completed, self.description))
  File "/usr/local/lib/python2.4/site-packages/trac/db/util.py", line 50, in execute
    return self.cursor.execute(sql_escape_percent(sql), args)
  File "/usr/local/lib/python2.4/site-packages/trac/db/sqlite_backend.py", line 56, in execute
    args or [])
  File "/usr/local/lib/python2.4/site-packages/trac/db/sqlite_backend.py", line 48, in _rollback_on_error
    return function(self, *args, **kwargs)
OperationalError: SQL logic error or missing database

my trac is versioned 0.10.3, hosted on FreeBSD, Python 2.4.3

Attachments (0)

Change History (3)

comment:1 by anonymous, 14 years ago

Duplicate of #3652?

comment:2 by Christian Boos, 14 years ago

Milestone: 0.10.5

Yes, a duplicate of #3652. Need also to consider that kind of exception for #6348.

comment:3 by Christian Boos, 14 years ago

Resolution: duplicate
Status: newclosed

(forgot to close this one)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.