Edgewall Software
Modify

Opened 18 years ago

Closed 16 years ago

#3652 closed defect (fixed)

Error when trying to create milestone with existing name

Reported by: finn@… Owned by: Christian Boos
Priority: high Milestone: 0.11.3
Component: roadmap Version: 0.9.6
Severity: normal Keywords: model
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description (last modified by Christian Boos)

If you try to create a new milestone with the same name as an existing one, you get a python error message and traceback. This should be handled gracefully with an instruction to the user about choosing another name.

Traceback (most recent call last):
  File "/usr/lib/python2.3/site-packages/trac/web/modpython_frontend.py", line 206, in handler
    dispatch_request(mpr.path_info, mpr, env)
  File "/usr/lib/python2.3/site-packages/trac/web/main.py", line 139, in dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.3/site-packages/trac/web/main.py", line 107, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/lib/python2.3/site-packages/trac/ticket/roadmap.py", line 355, in process_request
    self._do_save(req, db, milestone)
  File "/usr/lib/python2.3/site-packages/trac/ticket/roadmap.py", line 413, in _do_save
    milestone.insert()
  File "/usr/lib/python2.3/site-packages/trac/ticket/model.py", line 576, in insert
    (self.name, self.due, self.completed, self.description))
  File "/usr/lib/python2.3/site-packages/trac/db.py", line 219, in execute
    args or [])
  File "/usr/lib/python2.3/site-packages/trac/db.py", line 211, in _rollback_on_error
    return function(self, *args, **kwargs)
IntegrityError: column name is not unique

Attachments (0)

Change History (10)

comment:1 by Christian Boos, 18 years ago

Description: modified (diff)
Milestone: 0.10.1
Owner: changed from Christopher Lenz to Christian Boos

Right, the problem is still there.

comment:2 by Christian Boos, 18 years ago

Milestone: 0.10.10.10.2

(Sorry)

comment:3 by anonymous, 18 years ago

Somehow related to the problematic discussed in #4130.

comment:4 by Christian Boos, 17 years ago

Keywords: model added

comment:5 by Christian Boos, 17 years ago

Milestone: 0.10.50.11

Duplicate report: #4849.

comment:6 by Emmanuel Blot, 17 years ago

#5217 marked as a duplicate.

comment:7 by Christian Boos, 17 years ago

Priority: normalhigh

Yep, this one is pretty annoying and got reported often… moving up on the prio list.

comment:8 by Christian Boos, 17 years ago

Resolution: fixed
Status: newclosed

Fixed in r5276.

comment:9 by Christian Boos, 16 years ago

Milestone: 0.110.11.3
Resolution: fixed
Status: closedreopened

Hm, not really, renaming a milestone to an existing one still crashes.

comment:10 by Christian Boos, 16 years ago

Resolution: fixed
Status: reopenedclosed

Corrected in r7790 (0.11-stable) and r7793 (trunk).

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Christian Boos.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Christian Boos to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.