Edgewall Software
Modify

Opened 15 years ago

Closed 15 years ago

Last modified 7 years ago

#543 closed defect (wontfix)

Debian package

Reported by: anonymous Owned by: Jonas Borgström
Priority: normal Milestone:
Component: general Version: 0.7.1
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description

TracOnDebian works, for sure. The problem is that for python 2.1 neither notification nor diff works (maybe more… dunno). Could anyone enlightened create a packaged depending on python 2.2? Or add the steps required to exchange python2.1 with 2.2 while still using clearsilver etc.?

Attachments (0)

Change History (9)

comment:1 by anonymous, 15 years ago

Just for the record: I successfully installed Trac on a Debian/untsable machine. I had to download quicksilver (as it's not available for Debian, even though a RFP was file some time ago), and to build it. python2.3 was use while the compilation. And so far it seems to work :)

comment:2 by Christopher Lenz, 15 years ago

Milestone: 0.7.20.8

0.7.2 is cancelled

comment:3 by Jonas Borgström, 15 years ago

Email notification requires python ≥ 2.2.2 and Debian woody (stable) only comes with Python 2.2.1.

comment:4 by otavio@…, 15 years ago

Current version of Trac is packaged on unstable and works nice. I think this bug can be closed since it is not Trac problem but stable package version.

comment:5 by Jonas Borgström, 15 years ago

Resolution: wontfix
Status: newclosed

I'm closing this ticket because python 2.2.1 shipped with debian stable is also too old to get email notification to work, see my previous comment.

comment:6 by bryan@…, 15 years ago

Hi there,

I resolved this on debian stable (woody) and Trac 0.8 with the following:

apt-get install python 2.2
cd /usr/bin
mv python python.orig
ln -s python2.2 python
cp -R /usr/lib/python2.1/site-packages /usr/lib/python2.2
apache2 -k restart

Diffs work fine now; have not tried notification yet but I see no reason it would fail.

comment:7 by bryan@…, 15 years ago

oops. Actually, replace the first line in the above with:

apt-get install python2.2 python2.2-xmlbase python2.2-sqlite

comment:8 by bryan@…, 15 years ago

Ooops again. Today I tried enabling the mail notification system and discovered that Trac wants Python 2.2.2 or higher for that to work. Oh well! I couldn't locate anything above 2.2.1 for Debian/stable, so folks who want notifications should consider running testing or unstable and getting Python 2.3 or 2.4 I guess.

comment:9 by Christian Boos, 7 years ago

Milestone: 0.8

(clearing report:35)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.