Edgewall Software
Modify

Opened 12 years ago

Closed 12 years ago

#5423 closed defect (fixed)

repos.sync throws NoSuchChangeset

Reported by: csapuntz@… Owned by: Christian Boos
Priority: normal Milestone: 0.10.5
Component: version control Version: 0.10.4
Severity: normal Keywords: resync
Cc: Branch:
Release Notes:
API Changes:

Description (last modified by Emmanuel Blot)

It seems to me that a sync function shouldn't throw.

Stacktrace:
  File "/usr/bin/bitten-master", line 7, in ?
    sys.exit(
  File "build/bdist.linux-i686/egg/bitten/master.py", line 405, in main
  File "build/bdist.linux-i686/egg/bitten/util/beep.py", line 150, in run
  File "build/bdist.linux-i686/egg/bitten/master.py", line 66, in _enqueue_builds
  File "build/bdist.linux-i686/egg/bitten/queue.py", line 162, in populate
  File "/usr/lib/python2.3/site-packages/trac/versioncontrol/cache.py", line 102, in sync
    self.youngest = self.repos.normalize_rev(self.youngest)
  File "/usr/lib/python2.3/site-packages/trac/versioncontrol/svn_fs.py", line 312, in normalize_rev
    raise NoSuchChangeset(rev)
trac.versioncontrol.api.NoSuchChangeset: No changeset 9408 in the repository

Attachments (1)

fix-sync-race-0.10.5dev.patch (1.0 KB ) - added by Christian Boos 12 years ago.
Get the repository youngest_rev right before we call normalize_rev

Download all attachments as: .zip

Change History (8)

comment:1 by Emmanuel Blot, 12 years ago

Component: generalversion control
Description: modified (diff)
Owner: changed from Jonas Borgström to Christian Boos

comment:2 by Emmanuel Blot, 12 years ago

Have you recently upgraded to 0.10.4 ?

Try to run

trac-admin <project> resync

It may be a duplicate of #5259.

in reply to:  2 comment:3 by csapuntz@…, 12 years ago

We have been running 0.10.4 for at least a week now with many successful checkins and many successful bitten builds (though we have been seeing a lot of bitten crashes)

It looks like a race of some sort to me. bitten is in a separate process than trac.

Replying to eblot:

Have you recently upgraded to 0.10.4 ?

Try to run

trac-admin <project> resync

It may be a duplicate of #5259.

in reply to:  2 comment:4 by csapuntz@…, 12 years ago

BTW, I did a resync after we upgraded.

by Christian Boos, 12 years ago

Get the repository youngest_rev right before we call normalize_rev

comment:5 by Christian Boos, 12 years ago

Keywords: resync added
Milestone: 0.10.5
Status: newassigned

Can you please try attachment:fix-sync-race-0.10.5dev.patch and report back if the this fixes the problem?

comment:6 by anonymous, 12 years ago

Yes, this seems to fix our problem. Bitten has been up for 9 hours. Previously it crashed every 1:30 hrs or so, esp when trac was being used by our developers and checkins were happening.

comment:7 by Christian Boos, 12 years ago

Resolution: fixed
Status: assignedclosed

Ok, thanks for testing this. Patch applied in r5611 (trunk) and r5612 (0.10-stable).

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Christian Boos.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Christian Boos to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.