Edgewall Software
Modify

Opened 18 years ago

Closed 17 years ago

#520 closed enhancement (fixed)

line numbers in file view

Reported by: dju` Owned by: Christopher Lenz
Priority: low Milestone: 0.9
Component: version control/browser Version: 0.7.1
Severity: normal Keywords: helpwanted
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

It would be great to display the line numbers on the left side when viewing a file, obviously taking the line wraps in account.

Attachments (0)

Change History (5)

comment:1 by daniel, 18 years ago

Milestone: 1.0
Priority: normallow

This is difficult, due to the use of external libraries/tools (like enscript and silvercity) for fontlocking/syntax-highlighting of files. It's hard (if not impossible) to know how they output lines in the resulting HTML.

If either had line number display, it'd be trivial to add, of course.

Note: Since we already have a 'prettification' function in enscript.py , it might be possible to parse lines as well.

comment:2 by Christopher Lenz, 17 years ago

Keywords: helpwanted added
Milestone: 1.0
Severity: normalenhancement

comment:3 by Christopher Lenz, 17 years ago

Component: generalbrowser

#579 has been marked as duplicate of this ticket.

comment:4 by Christopher Lenz, 17 years ago

Milestone: 0.9
Owner: changed from Jonas Borgström to Christopher Lenz
Status: newassigned

I'm working on this.

comment:5 by Christopher Lenz, 17 years ago

Resolution: fixed
Status: assignedclosed

Implemented in [1764].

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Christopher Lenz.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Christopher Lenz to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.