Edgewall Software
Modify

Opened 15 years ago

Closed 15 years ago

Last modified 4 years ago

#519 closed defect (duplicate)

Python process sometimes hangs on Windows Server 2003

Reported by: Per Norman Owned by: Jonas Borgström
Priority: normal Milestone:
Component: general Version: 0.7
Severity: major Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description

We're running Trac 0.7 as CGI on Windows Server 2003 with Python 2.3.3, Subersion 1.0.4 and Apache 2.0.49.

Sometimes Trac (a Python process) hangs and locks the Subversion repository (Windows file lock). Trac still works on pages that don't interact with Subversion. All other hangs, waiting for the repository file lock.

To get on we have to kill all Python processes, stop Apache and run recover on the repository.

Any ideas why this happens?

Attachments (0)

Change History (2)

comment:1 by daniel, 15 years ago

I'm unable to reproduce this on Windows XP, Python 2.3.3, Subversion 1.0.1, Apache 2.x.

Could it be that your python process doesn't have permission to access some resource? Like, I know the console python CLI requires that magic ENV variable to allow terminal access. Is it something similar perhaps?

comment:2 by anonymous, 15 years ago

Resolution: duplicate
Status: newclosed

This is a duplicate of #571

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.