Edgewall Software
Modify

Opened 16 years ago

Closed 15 years ago

#5128 closed defect (duplicate)

font-weight has no effect in __style__ for report lines

Reported by: anonymous Owned by: Matthew Good
Priority: low Milestone:
Component: report system Version:
Severity: minor Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

The documentation for style indicates that a CSS style statement can be used to format lines in a report. I've found that some CSS style statements work (such as background-color) but some do not (font-weight for example does not). The example given in the instructions show font-weight being used, so I assume it's supposed to be supported.

Attachments (0)

Change History (3)

comment:1 by jtuchscherer, 15 years ago

In the trac.css there is a style defined for the td element. The style is defined like this:

body, th, td { font: normal 13px verdana,arial,'Bitstream Vera Sans',helvetica,sans- serif;

}

The font setting 'normal' in the css for font-style overwrites the css setting (font-style: bold;) in the <tr> element for the row that matches my criteria. So I changed the trac.css to the following:

body, th, td { font-size: 13px; font-family: verdana,arial,'Bitstream Vera Sans',helvetica,sans-serif;

}

That solved my problem and I have now bolded lines in my report.

I am running version .10.4

comment:2 by ThurnerRupert, 15 years ago

could you try with 0.11 pls? with easy_install trac, see wiki:0.11/TracInstall?

comment:3 by osimons, 15 years ago

Resolution: duplicate
Status: newclosed

Closing this as a duplicate of #2645 that seems to report exactly the same 'inconvenience'.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Matthew Good.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Matthew Good to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.