Edgewall Software
Modify

Opened 15 years ago

Closed 15 years ago

Last modified 15 years ago

#5127 closed enhancement (invalid)

Custom Query recording functionality - a quick fix?

Reported by: fkennedy Owned by: Matthew Good
Priority: normal Milestone:
Component: report system Version: 0.10.3.1
Severity: normal Keywords: query recording
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

what: The recording and listing of custom queries.

Why: After reading through the wiki's and some trac tickets on this subject I have now disabled the reporting module in our Trac installation. This is mainly because 1. As it has been deprecated I wish to start off in the right direction, and 2. We migrated from Bugzilla where our contributors were used to the query tool and not so concerned with producing SQL. So for our setup, being able to quickly access a preset list of queries is vital. I feel it would be more suitable to make these available on the Ticket View page.

How: For now I have simply placed links to custom reports in the main wiki page, allowing contributors to go directly to their chosen 'report'. But this is not so intuitive. I feel a fast and effective way to introduce SOME functionality in this area would be to simply include a short wiki window above the custom query where a user with WIKI_ADMIN can add links to pre-created custom queries to cover some of the contributors main requirements.

This ticket is not about full integration, more about getting a working solution untill the full functionality is introduced.

The reports/queries wiki requested feedback and thats what this ticket represents. HTH :-) F

Attachments (0)

Change History (2)

comment:1 by anonymous, 15 years ago

Resolution: invalid
Status: newclosed

I've gone back to reporting for now.

comment:2 by Christian Boos, 15 years ago

In 0.11, you'll be able to save custom queries as report (see #1735).

Then, like before, you could have a list of reports when selecting View Tickets, all of them pointing to saved custom queries if you wish so.

It'll also be possible to specify a default custom report to show directly when clicking on View Tickets, which is sometimes preferred (see #2060). Even specifying a wiki page containing links to queries or reports (or even embedded reports using the [[TicketQuery]] macro's new table mode).

The problems we had with reports was mainly with the exposure of the SQL, and the fact that this implies additional care when migrating to an other database backend or a newer Trac version (if the TracDev/DatabaseSchema changes).

(wanted to close this as duplicate of #1735, but as it's already closed… keeping as it is)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Matthew Good.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Matthew Good to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.