Edgewall Software
Modify

Opened 16 years ago

Closed 16 years ago

#5123 closed defect (duplicate)

cannot display source which '<script>' tag in it

Reported by: ukseong@… Owned by: Jonas Borgström
Priority: normal Milestone:
Component: general Version: 0.10.3
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

My source file has '<script>' and '</script>' in it and trac cannot display this source cause of them.

Traceback (most recent call last):

File "/usr/lib/python2.3/site-packages/trac/web/main.py", line 387, in dispatch_request

dispatcher.dispatch(req)

File "/usr/lib/python2.3/site-packages/trac/web/main.py", line 244, in dispatch

req.display(template, content_type or 'text/html')

File "/usr/lib/python2.3/site-packages/trac/web/api.py", line 358, in display

data = self.hdf.render(template, form_token)

File "/usr/lib/python2.3/site-packages/trac/web/clearsilver.py", line 296, in render

injector.feed(template.render())

File "/usr/lib/python2.3/HTMLParser.py", line 108, in feed

self.goahead(0)

File "/usr/lib/python2.3/HTMLParser.py", line 150, in goahead

k = self.parse_endtag(i)

File "/usr/lib/python2.3/HTMLParser.py", line 327, in parse_endtag

self.error("bad end tag: %s" % rawdata[i:j])

File "/usr/lib/python2.3/HTMLParser.py", line 115, in error

raise HTMLParseError(message, self.getpos())

HTMLParseError: bad end tag: '</script">', at line 162, column 201

Attachments (0)

Change History (2)

comment:1 by hyuga <hyugaricdeau@…>, 16 years ago

The traceback should answer your problem:

HTMLParseError: bad end tag: '</script">', at line 162, column 201

Somewhere in your template you must have </script"> instead of </script>

comment:2 by Matthew Good, 16 years ago

Resolution: duplicate
Status: newclosed

This appears to be a duplicate of #4365. The bug seems to be the result of a problem in SilverCity so please try upgrading SilverCity to 0.97.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.